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Chapter 2 Using SCT Banner
Introduction

2 Using SCT 
Banner 

This chapter describes the basic features of the SCT Banner System. Learning to use 
these features is the foundation for using Banner at your institution.

Most sample forms in this chapter were created in an Internet-native environment. 
Your forms may have subtle differences if you are running in a different 
environment. For example, buttons, scroll bars, radio groups, and checkboxes may 
look different if you are running in a Microsoft Windows environment. Most 
functionality is the same, however, regardless of your environment.

Starting SCT Banner

Using SCT Banner The steps for accessing Banner depend on your hardware, software, and network 
configuration. Because there are many ways to access Banner, this section does not 
give specific steps for launching your system. Instead, this section describes the 
common requirements for getting into Banner. Your institution’s implementation 
may be different.

To help ensure that only authorized users access Banner, you must log in with a 
username (user ID) and a password. Your institution may have additional network 
and operating system login and security procedures.

These are the common steps for starting Banner.

1. Use your institution’s procedures to start your workstation.

2. If you are running in an Internet-native environment, launch your Web 
browser and enter the URL used to access Banner.

OR

If you are running in a client/server environment, launch Oracle Runtime 
(Runform on some platforms).

3. Enter your username, password, and database (depending on your 
environment) at the logon prompts. If you enter a wrong username or 
password, you are prompted to reenter both. (Your institution determines the 
number of times you can try to log on.) 

Note: The database is required if you are running in an Internet-native 
environment. Depending on your setup, it may also be required if you are 
running in a client/server environment.
September 2002 SCT Banner Release 5.4
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Once you complete these steps, the SCT Banner main menu appears:

In this figure the Products Menu is expanded. Your institution may be using another 
menu as the default expanded menu on the main menu. Individual users can 
override the institution default and establish a personal default. See the SCT Banner 
General Technical Reference Manual for instructions on setting the institution default. 
See “To Identify the Default Expanded Menu in the Left Pane of the Main Menu” 
on page 2-114 for instructions on setting a personal default.

The main menu is the starting point for navigating through Banner. You can use the 
menus in the left pane to access a form, job, menu, or QuickFlow. Or you can use 
Direct Access to go to a specific form if you know the form’s name. Navigation is 
described in "Navigating Through Banner" on page 2-49. 

Using the Mouse and Keyboard

You can perform most Banner functions with either a mouse or keyboard. For 
example, you can save information by clicking a button on the toolbar, selecting an 
item from a pull-down menu, or pressing equivalent keystrokes.

Because you can choose from several methods, this chapter does not usually tell you 
specifically how to perform a function. Instead, the instructions say to “select” the 
function. Mouse and keyboard instructions are given only if they are distinctly 
different from each other. Two symbols appear throughout this chapter to indicate 
the different sets of instructions:

Use menus to
navigate through

Banner.

 Use Direct Access to
access a specific form.
 SCT Banner Release 5.4 September 2002
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Keyboard Equivalents

Specific keystrokes for a function depend on your environment. For example, Enter 
Query might be F7 in one environment and F11 in another. Because keystrokes vary 
from one environment to another, they are not described in this manual. Show Keys 
is a valuable tool that helps you use the keyboard. This function lists the keyboard 
equivalents available in your environment for the current form, window, and field.

Some Banner forms use a right-mouse click as an alternative to keyboard functions. 
Oracle does not currently support the right-mouse click function in Internet-native 
mode. (Oracle may support this function in future releases.) Any Banner error 
messages and auto hints that mention a right-mouse click should be disregarded in 
Internet-native Banner.

To display keyboard equivalents:

Mouse instructions

Keyboard instructions

 

Click the Show Keys button on the 
toolbar.

Select Help>Show Keys.

OR 

Use the keystrokes for the Show Keys 
function. (Check with your data center 
personnel for these keystrokes.)

Show Keys lists the keyboard 
equivalents that are available 
in your environment for the 
current form, window, and 
field.
September 2002 SCT Banner Release 5.4
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Quick Reference Chart

You can complete the chart on the next page and use it as a quick reference for 
keyboard equivalents at your institution. First use Show Keys to determine the 
equivalent for each option on the Banner pull-down menus. Then record each 
equivalent on the chart. You can post the chart for easy reference.

See "Menu Bar" on page 2-23 for details on each pull-down menu option.
 SCT Banner Release 5.4 September 2002
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Direct Access

Object Search

QuickFlow

Select

Rollback

Save

Print

Exit

Exit QuickFlow

Preferences

Refresh

Copy

Paste

Edit

Cut

File Options Block Item Record Query HelpEdit

Extract Data
No Key

Technical
Support

Previous

Next

Clear

Previous

Next

Clear

Duplicate

Previous

Next

Scroll Up

Scroll Down

Clear

Remove

Insert

Duplicate

Lock

Enter

Execute

Last Criteria

Cancel

Count Hits

Fetch Next Set

Online Help

Dynamic
Help Query

Dynamic
Help Edit

SCT Banner
Bookshelf

Help (Item
Properties)

Show Keys

List

Display Error

Display
ID Image

Calendar

Calculator

Extract Data
with Key

SCT Banner
XtenderSolutions

About SCT
Banner

SCT Banner
XtenderSolutions
Info

Varies by form
September 2002 SCT Banner Release 5.4
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Naming Conventions

2 Using SCT 
Banner 

Banner form, report, job, and table names have the following structure:

Position 1 
identifies the 
primary system 
owning the 
form, report, 
job, or table. 
(See note on 
page 2-11.)

A Alumni/Development K Work Management T Accounts Receivable
B Property Tax L Occupational Tax/License U Utilities
C Courts N Position Control V Voice Response
D Cash Drawer O Customer Contact X Records Indexing
E XtenderSolutions P HR/Payroll/Personnel W

Y
Z

Reserved for client
applications that co-exist
with Banner

F Finance Q Electronic Work Queue
G General R Financial Aid
I Information Access S Student

Position 2 
identifies the 
module owning 
the form, report, 
job, or table.

Alumni/Development (A) Financial Aid (R)
HR/Payroll/Personnel (P)

Position Control (N)
A Membership B Budgeting A Application
D Designation C Record Creation B Budget
E Event Management E Electronic Data Exchange C COBRA
F Campaign F Funds Management D Benefit/Deductions
G Pledge and Gift/Pledge 

Payment
H History and Transcripts E Employee
J Student Employment H Time Reporting/History

L Label L Logging O Overall
M Prospect Management N Need Analysis P General Person
O Organization O Common Functions R Electronic Approvals
P Constituent/Person P Packaging & Disbursements S Security
S Solicitor Organization R Requirements Tracking T Validation/rule table
T Validation form/table S Student System Shared Data U Utility
U Utility T Validation form/table V Reserved-Can. Solution Ctr.
V Reserved-Can. Solution Ctr. U Utility X Tax Administration
X Expected Matching Gift V Reserved-Can. Solution Ctr.

Finance (F) General (G) Student (S)
A Accounts Payable E Event Management A Admissions
B Budget Development J Job Submission C Catalog
C Cost Accounting L Letter Generation E Support Services
E Electronic Data Interchange O Overall F Registration/Fee Assessment
F Fixed Assets P Purge G General Student
G General Ledger S Security H Grades/Academic History
I Investment Management T Validation form/table I Faculty Load
N Endowment Management U Utility K Reserved-SCT Intntl. UK
O Operations V Reserved-Can. Solution Ctr. L Location Management
P Purchasing/Procurement X Cross product M CAPP
R Research Accounting Accounts Receivable (R) O Overall
S Stores Inventory F Finance Accounts Receivable P Person
T Validation form/table G General Accounts Receivable R Recruiting
U Utility O Overall S Schedule
V Reserved-Can. Solution Ctr. R Research Accounting T Validation form/table
X Archive/Purge S Student Accounts Receivable U Utility

Information Access/Kiosk (I) T Validation form/table V Reserved-Can. Solution Ctr.
R Financial Aid U Utility XtenderSolutions (E)
S Student V Reserved-Can. Solution Ctr. T Validation form/table

X XtenderSolutions
All Products

W
Y
Z

Reserved for client forms or modules used within a Banner application
(character in position 1 does not equal W, Y, or Z)
 SCT Banner Release 5.4 September 2002
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Examples

Note The system identifier in position 1 can be one or two characters long. If the 
identifier is one character long, the form, report, job, or table name is seven 
characters long. If the identifier is two characters long, the name is eight characters 
long.

Position 3 
identifies the 
type of form, 
report, job, or 
table.

Alumni/Development (A) Financial Aid (R)
HR/Payroll/Personnel (P)

Position Control (N)
A Application form A Application form A Application form
B Base table B Base table B Base table

Batch COBOL processC Called/list form I Inquiry form
I Inquiry form P Process/report I Inquiry form
P Process/report R

 
Rule table
Repeating rules table
Report

P Process
R Repeating rules table R Rule table

Repeating table
Report/process

T Temporary table
V Validation form

View
T Temporary table
V Validation form/table

View
V Validation form/table

Finance (F) General (G) Student
A Application form A Application form A Application form
B Base table B Base table

Batch COBOL process
B Base table

I Inquiry form I Inquiry form
M Maintenance form I Inquiry form P Process
Q Query form O Online COBOL process Q Query form
R Rule table

Repeating table
Report/process

Q Query form R Rule table
Repeating table
Report/process

R Rule table
Repeating table
Report/processV Validation form/table

View
V Validation form/table

ViewT General maintenance
Temporary tableAccounts Receivable (T) Information Access/Kiosk (I)

A Application form V Validation form/table
View

R Report
I Inquiry form
P Process XtenderSolutions (E)
Q Query form A Application form
R Report V Validation form/table
V Validation form/table

Positions 4, 5, 6, and 7 uniquely identify the form, report, job, or table.

FOAIDEN FGAENCB FOIDOCH
F Finance F Finance F Finance
O Operations G General Ledger O Operations
A Application A Application I Inquiry
IDEN Identification ENCB Encumbrance DOCH Document History
September 2002 SCT Banner Release 5.4
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What Is a Form?

2 Using SCT 
Banner 

A form is an online document where you can enter and look up information in your 
database. A form visually organizes information so it is easier to enter and read. A 
Banner form is similar to a paper form, except information is entered once and then 
used by other forms, reports, and jobs.

Forms can include windows, window panes, dialog boxes, and alert boxes.

Windows

A window is a framed portion of a form. Just as some paper forms have multiple 
pages, some Banner forms have multiple windows. The first window in a form is 
called the main window and is identified by the form name. All other windows in the 
form have their own unique names.

More than one window can be open at the same time. The only limits are 
determined by the amount of memory installed on your system. Not all windows are 
the same size, so you might see parts of more than one window at the same time.

You can move a window by dragging its title bar to a new location. (You cannot move 
the title bar above the screen.) Your environment may let you resize and move 
windows in other ways. Refer to the documentation for your environment.

Caution: Banner windows do not use the close button ( ) in the upper right 
corner.

This form has three
open windows:

Expenses window

Meeting Time window

 main window

The Meeting Time window is
the active window, indicated

by the highlighted title bar.
 SCT Banner Release 5.4 September 2002
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Window Panes

A window pane is an area within a window that has more fields than can appear at 
one time. A solid line usually borders a pane.

You can use the horizontal scroll bar at the bottom of a window pane to see the 
remaining fields in the pane. You cannot see all fields at one time.

To scroll through the fields in a window pane:

This is another window pane.

This is a window pane.

A horizonal scroll bar always
appears under a window pane.

 

Click and drag the scroll box right or 
left. 

OR

Click the arrow at either end of the scroll 
bar.

Select the Next Item function (to move 
to the right) or the Previous Item 
function (to move to the left).

Note: The cursor skips display-only fields, 
moving only to enterable fields. 
September 2002 SCT Banner Release 5.4
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Dialog Boxes

A dialog box is a window that appears when you must choose from two or more 
responses.

You must acknowledge a dialog box before you can do anything else on the form.

To acknowledge a dialog box:

Alert Boxes

An alert box is a window that notifies you of a condition that may impact data. For 
example, this alert box may appear if you try to enter information for a deceased 
person:

You must acknowledge an alert box before you can do anything else on the form.

To acknowledge an alert box:

 

Click the button you want. 1. Select the Next Item function to 
move to the button you want. 

2. Press Enter.

 

Click the OK button. Press Enter.

This dialog box has three 
possible responses.

An alert box always has one response.
 SCT Banner Release 5.4 September 2002
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Types of Forms

2 Using SCT 
Banner 

The Banner Finance System uses six types of forms:

Maintenance, rule, and control forms are used to tailor Banner to your institution’s 
procedural requirements when Banner is implemented. You can make revisions 
with these forms any time, if your security level permits. 

Main menu Use this form to navigate through Banner. It provides an 
overview of the menus, forms, jobs, and QuickFlows in the 
system.

Application forms Use these forms to enter, update, and query information. This is 
one of the most common types of forms.

Maintenance 
forms

Use these forms to establish criteria that are crucial to the 
processing of information entered on application forms. This is 
one of the most common types of forms.

Validation forms Use these forms to see the values that are defined on 
maintenance forms.

Rule and control 
forms

Use these forms to define the calculations, parameters, and rules 
that impact processing on other forms, reports, and jobs.

Inquiry and query 
forms

Use these forms to look up existing information, often returning 
information to the calling form.

Note: If the third character of a form name is Q, you must 
access the form from another form. You cannot access 
it directly from the main menu, with Direct Access, or 
with Object Search.
September 2002 SCT Banner Release 5.4
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Main Menu

The main menu provides an overview of the menus, forms, jobs, and QuickFlows in 
Banner. You can use the main menu to navigate through Banner. See "Navigating 
Through Banner" on page 2-49 for instructions on using the main menu to navigate.

The main menu has a familiar Windows format:

• The left pane shows the various levels of menus at your institution. Standard 
menus are delivered with Banner, but your institution can reorganize and add 
menus to meet your specific needs.

• The right pane shows the contents of the menu that is selected in the left pane. 

Menus in the Left Pane

The left pane of the main menu displays three menus:

• Business Processes Menu. This menu organizes menus, forms, jobs, and 
QuickFlows according to the way your institution does business. This menu 
focuses on how you perform daily operations in four areas: Manage the 
Enterprise, Matriculate to Educate, Forecast to Enroll, and Plan to Fund.

• Products Menu. This menu organizes menus, forms, jobs, and QuickFlows by 
the following Banner products: Student, Alumni/Development, Finance, 
Human Resources, Financial Aid, General, and Banner XtenderSolutions.

left pane right pane

expanded menu

collapsed menu

The currently selected menu is
highlighted. Items in this menu

appear in the right pane.
 SCT Banner Release 5.4 September 2002
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• Personal Menu. This menu contains the menus, forms, jobs, and QuickFlows 
most important in the workday of the individual user. This menu is tied to a 
user’s Oracle user ID.

SCT delivers the main menu with the Products Menu expanded. During installation, 
your system administrator can establish another menu as the default expanded 
menu. Individual users can override the institution default and establish a personal 
default for the menu that is expanded on the main menu. See the SCT Banner 
General Technical Reference Manual for instructions on setting the institution default. 
See “To Identify the Default Expanded Menu in the Left Pane of the Main Menu” 
on page 2-114 for instructions on setting a personal default.

Expanding and Collapsing Menus

Menus in the left pane can be expanded and collapsed:

• When a menu is expanded, the next level of menus is visible.

• When a menu is collapsed, the next level does not appear. 

By expanding and collapsing menus, you can easily navigate through Banner. See 
“To Expand a Menu” and “To Collapse a Menu” on page 2-50 for instructions on 
expanding and collapsing menus.

Customizing Menus

You can use the following forms to customize menus for your entire institution or 
individual users:

Menu Maintenance 
Form (GUTGMNU)

Lets you create custom menus for your institution. See 
“Customizing Menus” in chapter 4, Processing, of Using 
SCT Banner General..

Personal Menu 
Maintenance Form 
(GUAPMNU)

Lets you create a Personal Menu for an individual user. 
See "Personal Menu" on page 2-101.

Personal Menu Copy 
Form (GUTPMNU)

Lets you copy a Personal Menu from one user to other 
users. See "Personal Menu" on page 2-101.
September 2002 SCT Banner Release 5.4
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Application Forms

Application forms are used to enter, update, and query information in Banner. This 
is one of the most common types of forms.

The Clause Entry Form (FOACLAU) is an example of an application form.
 SCT Banner Release 5.4 September 2002
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Maintenance Forms

Maintenance forms are used to establish criteria that are crucial to the processing of 
information entered on application forms. Maintenance forms are used during 
implementation to customize the Finance System to meet your institution’s specific 
needs. For example, maintenance forms are used to set up your chart of accounts.

Maintenance forms, application forms, and validation forms are related. Valid 
information is first established on a maintenance form. This information can then 
be entered on application forms and displayed on validation forms. For example, 
you can define valid account types on the Account Type Code Maintenance Form 
(FTMATYP). You can then enter any of these account types in an Account Type field 
on an application form. If you wish, you can display the Account Type Validation 
Form (FTVATYP) to see a list of valid account types. If you try to enter a code that is 
not on the validation form, an error occurs and a message appears in the Auto Hint.

Most maintenance forms are completed when Banner is implemented. If your 
security level permits, you can use a maintenance form to enter new values or update 
existing ones. Remember, you can only change values with a maintenance form, not 
through a validation form or LOV window.

Note: SCT recommends that you do not change any seed data that are entered 
during the installation process. You can use maintenance forms to create 
new data or change existing date defined for your institution.

The Chart of Accounts Code Maintenance Form (FTMCOAS) is an example of a 
maintenance form.
September 2002 SCT Banner Release 5.4
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Validation Forms

Validation forms are used to see the values that are defined on maintenance forms. 
Each validation form in the Finance System is associated with a maintenance form. 
For example, the Account Type Validation Form (FTVATYP) supports the Account 
Type Code Maintenance Form (FTMATYP).

Values on a validation form make up a field’s List of Values (LOV). Banner uses 
LOVs to validate many fields. When the cursor is in a field that must be validated, 
List of Values appears in the status line, indicating that the entry must come from 
the LOV. If you try to enter a value that isn’t in the LOV, an auto hint message 
appears. See "Entering Information Into Validated Fields" on page 2-56 for more 
information.

The System Data Validation Form (FTVSDAT) is an example of a validation form.
 SCT Banner Release 5.4 September 2002
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Rule and Control Forms

Rule and control forms are used to define the calculations, parameters, and rules 
that impact processing on other forms, reports, and jobs. If you have the appropriate 
security access, you can enter new rules and controls or update existing ones.

The Control Account Maintenance Form (FTMACTL) is an example of a rule and 
control form.
September 2002 SCT Banner Release 5.4
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Inquiry and Query Forms

Inquiry and query forms are used to look up existing information, often returning 
information to the calling form.

You can access an inquiry form from the main menu, from another form, with Direct 
Access, or with Object Search.

If the third character of a form name is Q, the form is a query form. You must access 
it from another form. You cannot access it from the main menu, with Direct Access, 
or with Object Search.

The Check Payment History Form (FAICHKH) is an example of an inquiry form.
 SCT Banner Release 5.4 September 2002
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Parts of a Form

2 Using SCT 
Banner 

The following figure shows a sample form in a client/server environment. The form 
looks nearly the same in Internet-native Banner. There are only two differences:

• A form in Internet-native Banner does not have a navigation frame.

• A form in Internet-native Banner does not have a vertical toolbar.

Each part of the form is described on the following pages.

Menu Bar

The Banner menu bar, located at the top of every form, contains pull-down menus.

You can access an option in a pull-down menu at any time, except when you are in 
a dialog box, alert box, or List of Values (LOV). (You must respond to these windows 
before you can access a pull-down menu.)

menu bar

horizontal toolbar

vertical toolbar
title bar

navigation frame

key block

other blocks

auto hint

status line
September 2002 SCT Banner Release 5.4
Confidential Using SCT Banner Finance 2-23



Chapter 2 Using SCT Banner
To access an option in the menu bar:

Note: If a pull-down menu item is dimmed, that menu item is currently 
disabled and cannot be accessed.

File Menu

This pull-down menu contains standard Banner and Oracle functions. The bottom 
of the menu lists the last forms (up to ten) you accessed in this session. You can select 
any form in this list to re-access it.

Some of the menu items let you call another form, job, or QuickFlow. When you exit 
the called object, you return to the object you were previously using.

 

1. Click the desired pull-down menu 
name. Menu items appear.

2. Click the desired menu item.

1. Press the Alt key. The cursor moves 
to the menu bar.

2. Use the right and left arrow keys to 
highlight the desired pull-down 
menu name. Then press Enter.

OR

Press the underlined letter for the 
desired pull-down menu name.

3. Use the up and down arrow keys to 
highlight the desired menu item. 
Then press Enter.

OR

Press the underlined letter for the 
desired menu item.

Note: The Options pull-down menu may 
have multiple menu items that begin 
with the same letter. In Internet-native 
Banner, you must use the up and down 
arrow keys to select the desired menu 
item. In a client/server environment, 
you can press the underlined letter 
multiple times to highlight the desired 
item. Then press Enter.
 SCT Banner Release 5.4 September 2002
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Direct Access Displays the Direct Access Form (GUAPARM), which is used to 
access a form by its name. See "Direct Access" on page 2-50.

Object Search Displays the Object Search Form (GUIOBJS), which is used to 
search for a menu, form, job, or QuickFlow with part of the 
name, description, or type. See "Object Search" on page 2-51.

QuickFlow Displays the QuickFlow Form (GUAQFLW), which is used to 
access a QuickFlow. See "QuickFlow" on page 2-55.

Select Returns you to the calling form and enters the selected value 
into the field that called the form.

Rollback Application and inquiry forms
Clears all information (except key information) and returns 
you to the first enterable field in the key block.

Validation forms
Returns you to the first enterable field on the form.

Query forms
Returns you to the first enterable field on the calling form.

Save Saves all changes entered since the last time you saved.

Refresh Clears the message line.

Print Prints the current window with the date and time in the title 
bar.

Exit Forms and windows
Exits you from the form or window.

Main menu
Exits you from Banner.

Query mode 
Cancels the query and takes the form out of query mode.

Exit QuickFlow Exits you from a QuickFlow.

Preferences Displays the Personal Preferences Maintenance Form 
(GUAUPRF), which is used to customize Banner for individual 
users. See "Customized Toolbars" on page 2-111, "Title Bar 
Display Options" on page 2-113, "Displayed Form Names" on 
page 2-113, and "Customized Main Menu" on page 2-114.
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Edit Menu

This pull-down menu contains the functions used to edit text items.

Options Menu

This pull-down menu contains navigation options. In a client/server environment, 
these same navigation options also appear in the navigation frame.

Navigation options vary from form to form and depend on where the cursor is 
currently located. Some options take you to other blocks and windows within the 
current form. Other options take you outside the current form to related forms. For 
options that take you outside the current form, you can optionally display the form 
name associated with the option. You can set up this display option on the General 
User Preferences Maintenance Form (GUAUPRF). See "Displayed Form Names" on 
page 2-113.

SCT delivers Banner with standard navigation options. Your system administrator 
can use the Options Maintenance Form (GUAOPTM) to change and add navigation 

SCT Banner 
XtenderSolutions

If SCT Banner® XtenderSolutions™ 1 is installed, displays a list 
of documents that match the query criteria for the current 
cursor location. 

SCT Banner 
XtenderSolutions - 
Info

If SCT Banner® XtenderSolutions™ is installed, displays the 
number of documents that match the query criteria for the 
current cursor location. 

List of recently 
accessed forms

Lets you quickly re-access forms that were previously accessed 
in this session (up to ten). See "Last 10 Forms in the File Pull-
Down Menu" on page 2-56.

1.XtenderSolutions is a trademark of Legato Systems, Inc.

Cut Cuts selected text and places it on the clipboard.

Copy Copies selected text to the clipboard.

Paste Pastes text from the clipboard to the spot where the cursor is 
located.

Edit Displays the Editor window, which is used to enter or update text. 
You can display this window from most fields. It is particularly 
useful in long data fields. See "Using the Editor" on page 2-95.
 SCT Banner Release 5.4 September 2002
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options for your institution. Only those staff members with appropriate security can 
perform this task.

Note: Only the first 24 options defined on GUAOPTM will appear in the 
Options pull-down menu.

Block Menu

This pull-down menu contains the functions used to navigate among the blocks of 
information on a form.

Item Menu

This pull-down menu contains the functions used to navigate among the fields or 
items on a form.

Previous Moves the cursor to the previous block that has at least one 
enterable field. If the previous block is in another window, that 
window is opened.

Next Moves the cursor to the next block that has at least one enterable 
field. If the next area is in another window, that window is 
opened.

Clear Clears all information from the current block. (Information is 
not removed from any records or tables.)

Previous Moves the cursor to the previous enterable field (item) in the 
current block.

Next Moves the cursor to the next enterable field (item) in the current 
block. Occasionally, Next Item moves the cursor to the first 
enterable field (item) in the next block.

Clear Clears all information from the current field (item). 
(Information is not removed from any records or tables.)

Duplicate In a blank row of a repeating record, duplicates the contents of 
the same field (item) in the previous record and copies it into the 
new record.
September 2002 SCT Banner Release 5.4
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Record Menu

This pull-down menu contains the functions used to work with records on a form.

 

Query Menu

This pull-down menu contains the functions used to query information in the 
database based on specified criteria. See "Querying Information" on page 2-73.

Previous Moves the cursor to the first enterable field in the previous 
record and triggers previous record logic coded into the form.

Next Moves the cursor to the first enterable field in the next record of 
the current block and triggers next record logic coded into the 
form. If the cursor is in the last record, a new record is created.

Scroll Up Scrolls up the list of repeating records, putting the first displayed 
record near the bottom of the list.

Scroll Down Scrolls down the list of repeating records, putting the last 
displayed record near the top of the list.

Clear Clears all information from the current record. (Information is 
not removed from any records or tables.)

Remove Removes all information for the current record. When you Save, 
the removed information is deleted.

Insert Inserts a new blank record into the list of existing records.

Duplicate Duplicates the contents of all fields in the record and copies 
them into a new record.

Lock Temporarily locks the contents of the record so no other Banner 
user can update it. Save, Rollback, and Exit release the lock.

Enter Puts the form into query mode so you can enter search criteria to 
see what information is already in the database.

Execute Searches the database and displays the first set of records that 
match your search criteria.
 SCT Banner Release 5.4 September 2002
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Help Menu

This pull-down menu contains various help tools.

Last Criteria Enters the criteria from your last search.

Cancel Cancels the query and takes the form out of query mode.

Count Hits Counts the number of records that match the search criteria and 
displays that number in the auto hint.

Fetch Next Set If more records match the search criteria than fit in the window, 
replaces the current set of displayed records with the next set.

Online Help Displays online information for the current field. See "Online 
Help" on page 2-86.

Note: This option is disabled if online help is not available 
for the form.

Dynamic Help 
Query

Displays the Dynamic Help Form (GUAHELP) in query mode, 
which is used to display traditional help for a field, block, or 
form. See "Dynamic Help" on page 2-88.

Dynamic Help 
Edit

Displays the Dynamic Help Form (GUAHELP) in edit mode, 
which is used to edit traditional help for a field, block, or form. 
See "Dynamic Help" on page 2-88.

SCT Banner
Bookshelf

Provides electronic access to hardcopy Banner documents in the 
SCT Documentation Bookshelf. See "SCT Documentation 
Bookshelf" on page 2-92.

Help (Item 
Properties)

Displays the Oracle item properties window for the current field. 
See "Help (Item Properties)" on page 2-94.

Show Keys Displays the Keys list, which lists the functions and their 
equivalent keystrokes available in your environment for the 
current form, window, and field. See "Show Keys" on page 2-95.

List Displays the List of Values (LOV) for the current field if List of 
Values appears in the status line. See "Entering Information Into 
Validated Fields" on page 2-56.
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Windows Menu

This pull-down menu lets you arrange the open windows of a form.

Client/server:

Internet-native:

Display Error If an Oracle error occurs, displays the code that is in error.

Display
ID Image

If the cursor is in an ID field, displays the image associated with 
the ID, if available.

Calendar Displays the calendar. See "Using the Calendar" on page 2-84.

Calculator Displays the calculator. See"Using the Calculator" on page 2-85.

Extract Data 
with Key

Extracts Banner data for the current block, with key data, to a 
spreadsheet. See "Extracting Banner Data to a Spreadsheet" on 
page 2-80.

Extract Data
No Key

Extracts Banner data for the current block, without key data, to a 
spreadsheet. See "Extracting Banner Data to a Spreadsheet" on 
page 2-80.

Technical 
Support

Turns the SQL Trace feature on and off. SQL Trace is a tool that 
helps your technical support staff track performance issues that 
need to be resolved. See the SCT Banner General Technical Reference 
Manual.

About 
SCT Banner

Displays the About SCT Banner Form (GUAABOT), which 
identifies the current form, release number, date, and time.

Cascade Arranges each open window in a cascade.

Tile Arranges each open window in a tiled format (client/server 
environments).

Arrange Icons If an open window is collapsed into an icon, lets you move the 
icon (client/server environments).

Tile 
Horizontally

Arranges open windows above each other (Internet-native 
environments).

Tile Vertically Arranges open windows next to each other (Internet-native 
environments).
 SCT Banner Release 5.4 September 2002
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Toolbars

Toolbars contain iconic buttons that perform common functions. Banner has two 
toolbars:

• The horizontal toolbar appears directly under the menu bar. This toolbar is 
delivered with standard buttons.

• The vertical toolbar optionally appears on the left side of forms in a client/
server environment. (It is not available in Internet-native Banner.)

Your institution can make toolbar changes that apply to all users. In addition, 
individual users can customize the toolbars, depending on how your institution has 
set up the toolbars. See "Customized Toolbars" on page 2-111.

The following figure shows the toolbars in a client/server environment.

When you move your cursor to an iconic button and pause, a bubble appears with 
text that describe the function of the button.

Open windows Lists each currently open window in the active form. The active 
window is identified. You can make another window active by 
clicking the window name or entering the window number.

horizontal toolbar

bubble help that describes
the function of a button

vertical toolbar
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To access a toolbar button:

Click the appropriate iconic button. You can click a button any time, except when 
you are in a dialog box, alert box, or List of Values (LOV). (You must respond to 
these window before you can click a button.) If a button is dimmed, the button is 
disabled and cannot be clicked.

Note: No keyboard equivalents are available for using the toolbars.

Standard Buttons

Standard iconic buttons are delivered on the horizontal toolbar:

Customizing for Your Institution

The system administrator at your institution can use the General User Preferences 
Maintenance Form (GUAUPRF) to make toolbar changes that apply to all users. 
Only those staff members with appropriate security can perform this task.

Customizing for an Individual User

Individual users can customize their toolbars. See "Customized Toolbars" on page 
2-111 for instructions to:

• Display or hide the horizontal toolbar.

• Display or hide bubble help.

• Add buttons to either toolbar (even for functions external to Banner).

• Remove buttons from either toolbar.

Save
Rollback

Select

Insert Record
Delete Record

Enter Query
Execute Query
Cancel Query

Previous Record
Next Record
Previous Block
Next Block

View/Send Message
Print

Graph Information
XtenderSolutions

WF Open Electronic Document
WF Submit
WF Continue
WF Release

Show Keys
Bookshelf

Online Help
Exit
 SCT Banner Release 5.4 September 2002
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Title Bar

The title bar shows the following information:

• Descriptive form name

• Form name (seven or eight characters)

• Release number

• Database name from the Installation Control Form (GUAINST)

Individual users can remove any of this information except the descriptive form 
name. See "Title Bar Display Options" on page 2-113 for details.

Navigation Frame

The navigation frame is available in client/server environments. This frame appears 
on the left side of a form and shows the navigation options. These same options also 
appear in the Options pull-down menu.

Note: In Internet-native Banner you can use the Options pull-down menu 
instead of the navigation frame to display the first 24 options.

Navigation options vary from form to form and depend on where the cursor is 
currently located. Some options take you to other blocks and windows within the 
current form. Other options take you outside the current form to related forms. 

For options that take you outside the current form, you can optionally display the 
form name associated with the option. The optional name appears as bubble help. 
You can set up this display option on the General User Preferences Maintenance 
Form (GUAUPRF). See "Displayed Form Names" on page 2-113.

SCT delivers Banner with standard navigation options. The system administrator at 
your institution can use the Options Maintenance Form (GUAOPTM) to change 
and add navigation options for your institution. Only those staff members with 
appropriate security can perform this task.

Note: There is no limit to the number of options that can be displayed in the 
navigation frame. However, only the first 24 options will appear in the 
Options pull-down menu.

See "Navigation Frame" on page 2-52 for details on using the navigation frame.

form description form name

release number database name
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These options take you to
blocks within the form.

This option takes you outside
the form to a related form.

Bubble help appears when
you move the cursor over

an option that takes you
outside the form.
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Blocks

A block is a section of a form or window that contains related information. If a form 
or window contains more than one block, each block (except the key block) may be 
enclosed in a beveled box.

Most blocks have a title. There are three exceptions:

• A key block does not have a title.

• If a form or window has only one block, the block does not have a title.

• If a form has a key block and only one other block, the second block does not 
have a title.

Key Block

The first block on most forms contains key information. (Some forms, especially 
validation forms and certain list forms, do not have a key block.) The key block 
determines what is entered or displayed on the rest of the form. All information on 
the form refers to the key block.

The key block has at least one field and sometimes more. For example, a form that 
maintains financial information may have key block fields for both a chart of 
accounts and a fiscal year.

The key block stays on the form as subsequent blocks appear. Occasionally, another 
window may appear on top of the key block if the window is unusually large or if the 
key block is not pertinent to the window.

key block

other blocks
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When the cursor is in the key block, enterable fields in the key block are enabled. 
When you leave the key block, enterable fields in the key block are disabled.

Other Blocks

Other blocks contain additional details for the key information. Each block contains 
related information and is usually enclosed in a beveled box.

Auto Hint

The auto hint at the bottom of the form can contain the following information for 
the field where the cursor is located:

• Brief field description

• Error and processing messages

• Keyboard equivalents, if you can access other blocks, windows, or forms from 
the field

Status Line

The status line directly under the auto hint can contain one or more of the following 
messages:

Record n/n Shows the number of the current record followed by the total 
number of records in the current block. If there are more records 
than fit in the window, the total appears as a question mark (for 
example, 3/?) until you scroll to the last record in the block. Once 
the last record is displayed, the total appears as a number (for 
example, 3/15).

List of Values Indicates the field has a List of Values; see "Entering Information 
Into Validated Fields" on page 2-56.

Enter Query Indicates the form is in query mode.

field description

keyboard equivalents:
LIST to display person IDs
COUNT QUERY HITS to display nonperson IDs

status line
 SCT Banner Release 5.4 September 2002
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Elements on a Form

The following figure shows various elements that appear on forms. Each element is 
described on the following pages.

Buttons

Buttons are visual images used to perform an action or respond to the system. 
Banner forms use iconic buttons and response buttons.

Iconic Buttons

These buttons are small squares that contain an icon (picture). They represent one 
or more actions that can be performed for the associated field or record. For 
example, you can use iconic buttons to display a validation form for the field, copy 
a record, or display a window for entering freeform text.

iconic buttons

radio buttons

fields

checkbox

record

vertical
scrollbar
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Banner forms use the following iconic buttons. (Some products do not use all 
buttons.)

Search

Displays another form or window where you can search for a 
value or information related to the field. You can often select and 
return a value to the associated field.

Note: Sometimes the Search button can perform more than 
one function. In these cases, an Option List appears. 
You can select an option from the list.

Data

Indicates that data is available for the associated field.

No Data

Indicates that no data is available for the associated field. 

Summary

Displays summary information for the associated record.

Detail

Displays details for the associated record.

In Process

Indicates the process has started but is not complete.

Complete

Indicates the process is complete.

Maintenance

Updates information in the database.

Copy

Copies the current record or records.
 SCT Banner Release 5.4 September 2002
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If a field has an iconic button, the auto hint identifies the equivalent function that 
can be used instead of the button. If the button can perform more than one 
function, each equivalent is identified in the auto hint. 

To select an iconic button:

Response Buttons

These buttons are shaded rectangles that appear in alert boxes and dialog boxes. An 
alert box has one response button. A dialog box has two or more response buttons. 
You must use the buttons to respond to the system before you can continue. 

To select a response button in an alert box:

Comments

Displays a window where you can enter freeform text for the 
associated record.

Calculate

Performs a calculation on data in the associated field.

Approve

Indicates the process is approved.

Disapprove

Indicates the process is not approved.

 

1. Click the button.

2. If an Option List appears, click the 
desired option.

Otherwise, the form or window 
appears automatically.

1. Select the Next Item function until 
you reach the field that has the 
button.

2. Read the auto hint and select the 
equivalent function. (A field may 
have more than one option.)

 

Click the OK button. Press Enter.
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To select a response button in a dialog box:

Checkboxes

Selected:

Not selected:

Checkboxes are small boxes used to enable or disable features or options. When an 
option is enabled, a check mark appears in the checkbox. When the option is 
disabled, the checkbox is empty. 

Checkboxes often represent yes/no conditions. For example, the first sample on the 
left indicates the record has more detail. The second sample indicates the record 
does not have more detail. Sometimes checkboxes indicate navigation to other 
windows. The auto hint tells you when a checkbox is used for this kind of navigation. 

To select or clear a checkbox:

Radio Buttons

Radio buttons are small circles used to select one of several options in a group. Each 
radio button represents a choice for the group. You can pick only one radio button 
in a group. When you select a radio button, the previously selected button is cleared. 
In the sample on the left, the Both button is selected. 

 

Click the desired button. Select the Next Item function or use the 
left and right arrow keys to move to the 
desired button. Then press Enter.

OR

Press the underlined letter on the 
desired button.

 

Click the checkbox. If the box was 
unchecked, it is now checked. If the box 
was checked, it is now unchecked.

1. Select the Next Item function to 
move to the checkbox. 

2. Press the space bar. If the box was 
unchecked, it is now checked. If the 
box was checked, it is now 
unchecked.

Note: If the space bar does not toggle a 
checkbox, it may not be defined on 
your system. Check with your data 
center personnel.
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To select a radio button:

Scroll Bars

Scroll bars are used to display overflow information when a form has more 
information than can be displayed at once. They also indicate that a form has an 
unlimited number of repeating records. 

A scroll bar has an arrow on each end and a scroll box in the middle. The position 
of the scroll box shows approximately how far you are from the top/bottom or the 
right/left side of the window.

Forms can have two kinds of scroll bars:

• A vertical scroll bar, located directly to the right of the rows, indicates there are 
more records than are shown. A record can have one or more fields and one or 
more lines. A vertical scroll bar is disabled if all the records appear at once. 

• A horizontal scroll bar, located directly under the window, indicates there are 
more columns of information than are shown. 

To use a scroll bar:

 

Click the radio button. 1. Select the Next Item function to 
move to the radio group.

2. Press the left or right arrow key to 
move to the desired radio button. 

 

Click and drag the scroll box up/down 
(vertical) or left/right (horizontal).

OR

Click the arrow at either end of the scroll 
bar. The scroll box moves in the 
direction of the arrow.

OR

Click anywhere in the scroll bar. The 
scroll box moves between the previous 
location and where you click.

1. Select the Next Item function to 
move to one of the fields controlled 
by the scroll bar.

2. To move up and down (vertical 
scroll bar), select the Next Record 
or Previous Record function.

OR

To move left and right (horizontal 
scroll bar), select the Next Item or 
Previous Item function.
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Fields

Note: A field is sometimes called an item. This is the case in the names of the 
functions Next Item, Previous Item, and Duplicate Item. 

Fields are areas on a form where you can enter, query, change, and display specific 
information. The following terms describe a field:

• Enabled. You can put the cursor in the field. Information in the field appears in 
black text.

• Disabled. You cannot put the cursor in the field. Information (if it exists) 
appears in gray text.

• Enterable. You can enter information in the field. The field is usually enabled. 
In certain situations, however, it may be disabled.

• Display only. You cannot enter information in the field.

Some fields are usually enabled but may be disabled occasionally. For example, in 
query mode sometimes you can’t query a field that is normally enabled, and 
sometimes you can query a field that is normally disabled. This is also true for 
enabled fields in a key block; once you leave the key block, all fields in the key block 
are disabled.

The color of some field names is blue. This means a special code/description 
lookup feature is available for the field. See "Entering Information Into Validated 
Fields" on page 2-56.

Text fields may appear to be a few characters longer than they actually are. For 
example, a field that allows up to sixty characters may look like it still has space after 
the sixtieth character. This is because each character uses a different amount of 
space.

To access an enterable field:

 

Click the field. Select the Next Item function until the 
cursor is in the field.
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Gray is the default color for disabled fields. You can change a registry setting that 
controls the color and intensity of the Disabled Text attribute.

To change the color and intensity of disabled text:

1. Select Start>Run on your Windows toolbar. The Run window opens.

2. Enter regedit in the Open field.

3. Click the OK button. The Registry Editor window opens.

4. Navigate to HKEY_CURRENT_USER\Control Panel\Colors.

5. Double-click the Colors folder.

6. Double-click the Gray Text name. The Edit String window appears.

7. Enter 0 128 0 in the Value data field for a shade of green.

OR

Enter 0 0 128 in the Value data field for a shade of blue.

8. Click the OK button

9. Close the Registry Editor window.

10. Reboot your machine.

Note: It is your choice whether you keep the pale gray color, change it to green, 
or change it to blue. It is not recommended that you change disabled text 
to black (0 0 0), because you would not be able to distinguish enabled 
text from disabled text.
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Records, Rows, and Columns

Records are set of related fields. For example, a street, city, state, and ZIP/postal 
code form an address record.

If a block has multiple records, the records often appear in rows and columns. A 
horizontal scroll bar appears under the columns if all columns don’t fit into the 
window at once. A vertical scroll bar appears on the right side of the rows if all rows 
don’t fit into the window at once. When you select a row, the entire record is 
highlighted to identify it as the current record.

This sample shows a form with multiple printer records:

The current record
is highlighted.

A horizontal scrollbar
indicates all columns don’t
fit in the window at once.

A vertical scrollbar
indicates all rows don’t fit

in the window at once.
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Pull-Down Lists

Pull-down lists are used to select a field value from a list of pre-defined values. A 
down arrow in the right side of the field indicates the field has a pull-down list.

To select a value from a pull-down list:

 

1. Click the field. The entire pull-
down list appears with the currently 
selected item highlighted.

2. Click the desired item. The selected 
value appears in the field.

1. Select the Next Item function to 
move to the pull-down list.

2. Press the down arrow key. The 
entire pull-down list appears with 
the currently selected item 
highlighted.

3. Press the up and down arrow keys to 
move to the desired item.

OR

Type a character to highlight the 
next item that begins with that 
character. For example, to choose 
Inactive, type I. If more than one 
item starts with I, then the first item 
that starts with I is selected. 
Continue to press I until the correct 
choice appears.

4. Press Enter. The selected value 
appears in the field.
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Oracle Functions Used in Banner

2 Using SCT 
Banner 

Oracle functions trigger actions within a form. The following list describes the 
Oracle functions commonly used in Banner. For more complete technical 
descriptions, refer to your Oracle documentation.

Note: Banner sometimes redefines the standard Oracle functions to perform 
other functions. For example, Count Query Hits often calls another 
form. Use the Show Keys function to list the functions defined for the 
current form, window, or field.

Cancel Exits you from an Option List, List of Values, Editor window, 
or Dynamic Help without making a selection or saving 
information.

Clear Form See Rollback.

Commit See Save.

Count Hits See Count Query Hits.

Count Query Hits In query mode, counts the number of records that match the 
search criteria and displays that number in the auto hint. To 
retrieve records, select the Execute Query function.

Also referred to as Count Hits.

Down
(arrow key)

Moves the cursor to the first enterable field in the next 
record, moves you lower in a List of Values, or moves you 
lower in a pull-down list.

Down is similar to Next Record without next record logic.

Edit Displays the Editor window, which is used to enter or update 
text. It is particularly useful in long data fields.

Enter Query Puts the form into query mode so you can enter search 
criteria to see what information is already in the database. 
Enter Query appears in the status line. For more information, 
see "Querying Information" on page 2-73.

Execute Query In query mode, searches the database and displays all records 
that match your search criteria. For more information, see 
"Querying Information" on page 2-73.
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Exit Forms and windows
Exits you from the form or window.

Main menu
Exits you from Banner.

Query mode 
Cancels the query and takes the form out of query mode.

Also referred to as Exit without Value.

Exit with Value Called form 
Returns you to the calling form and enters the selected value 
into the field that called the form.

List of Values (LOV)
Returns you to the calling form and enters the highlighted 
value into the field that called the form. The OK button 
corresponds to Exit with Value.

Also referred to as Select and Next Primary Key.

Exit without Value See Exit.

Help Displays the Oracle item properties window for the current 
field.

List Displays the List of Values (LOV) for the current field if List 
of Values appears in the status line.

Next Block Moves the cursor to the next block that has at least one 
enterable field. If the next area is in another window, that 
window is opened.

Next Field See Next Item.

Next Item Moves the cursor to the next enterable field in the current 
block. Occasionally, Next Item moves the cursor to the first 
enterable field in the next block.

Also referred to as Next Field.

Next Primary Key See Exit with Value.
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Next Record Moves the cursor to the first enterable field in the next record 
of the current block and triggers next record logic coded into 
the form. If the cursor is in the last record, a new record is 
created.

Next Record is similar to Down with the addition of next 
record logic.

Previous Block Moves the cursor to the previous block that has at least one 
enterable field. If the previous block is in another window, 
that window is opened.

Previous Field See Previous Item.

Previous Item Moves the cursor to the previous enterable field in the 
current block.

Also referred to as Previous Field.

Previous Record Moves the cursor to the first enterable field in the previous 
record and triggers any previous record logic coded into the 
form.

Previous Record is similar to Up with the addition of previous 
record logic.

Rollback Application and inquiry forms
Clears all information (except key information) and returns 
you to the first enterable field in the key block. If you enter 
changes and do not save them before trying to roll back, you 
are prompted to save.

Validation forms
Returns you to the first enterable field on the form.

Query forms
Returns you to the first enterable field on the calling form.

Also referred to as Clear Form.

Save Saves all changes entered since the last time you saved.

Also referred to as Commit.

Scroll Down Scrolls down the list of multiple records, putting the last 
displayed record near the top of the list.

Scroll Up Scrolls up the list of multiple records, putting the first 
displayed record near the bottom of the list.
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Navigating Through Banner

Banner provides several ways to navigate through the system:

Select See Exit with Value.

Show Keys Displays the Keys list, which lists the functions and their 
equivalent keystrokes available in your environment for the 
current form, window, and field.

Up
(arrow key)

Moves the cursor to the first enterable field in the previous 
record, moves you higher in a List of Values, or moves you 
higher in a pull-down list.

Up is similar to Previous Record without previous record 
logic.

Main menu You can select from a list of the menus, forms, jobs, and 
QuickFlows in Banner.

Direct Access You can access a menu, form, job, or QuickFlow by its name.

Object Search You can access a form, job, or QuickFlow if you know part of its 
name, description, or type.

Navigation frame You can access other forms, windows, and blocks related to the 
current form, window, and block (available in client/server 
environments only).

Options menu You can access other forms, windows, and blocks related to the 
current form, window, and block.

Iconic buttons You can access another form or window related to the current 
record or field.

Mouse You can click an iconic button, field, record, block, or window 
that is currently displayed.

Keyboard 
equivalents

You can use the keyboard to access a form, window, block, or 
field.

QuickFlow You can automatically access forms that are linked in a chain.

Last 10 forms in 
the File pull-down 
menu

You can quickly re-access a form that was previously opened in 
the current session.
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Main Menu

You can use the main menu to select from a list of the menus, forms, jobs, and 
QuickFlows in Banner. The left pane shows the various levels of menus at your 
institution. Menus in the left pane are nested. You can easily navigate through 
Banner by expanding these menus. Contents of the currently selected menu appear 
in the right pane. Once you see the item you want in the right pane, you can select 
and access it.

See "Main Menu" on page 2-16 for a more detailed description of the main menu.

To expand a menu:

In the left pane, click the menu name. The menu name is highlighted, the next level 
of menus appears (if the menu includes more menus), and the contents of the 
menu appear in the right pane.

To collapse a menu:

In the left pane, click the name of the open menu. The next level of menus 
disappears (if the menu includes more menus). The contents of the selected menu 
remain in the right pane.

To quickly return to the Business Processes, Products, or Personal Menu:

Select the desired menu from the pull-down list above the left pane.

To access a menu item:

1. In the left pane, click the menu name you want to access. The contents of the 
menu appear in the right pane.

2. Continue expanding menus in the left pane until you see the form, job, or 
QuickFlow in the right pane. 

3. In the right pane, click the name of the form, job, or QuickFlow you want to 
access.

Direct Access

You can use Direct Access to access a menu, form, job, or QuickFlow by its name. You 
can use Direct Access from the main menu or from a form.

To use Direct Access from the main menu:

1. Enter the name of the menu, form, job, or QuickFlow in the Direct Access 
field.

2. Press Enter.
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Note: You can use the code/description lookup in the Direct Access field to 
activate Object Search. See "Object Search" on page 2-51 for details.

To use Direct Access from a form:

Note: When you use Direct Access from a form, the current form remains open. 
When you exit the requested form, job, or QuickFlow, you return to the 
original form.

1. Select File>Direct Access. The Direct Access Form (GUAPARM) appears.

2. Enter the name of the form, job, or QuickFlow in the Enter a valid name field. 
(You cannot use Direct Access to access a menu from a form.)

3. Click the Start button or press Enter.

Object Search

You can use Object Search to access a form, job, or QuickFlow if you know part of 
its name, description, or type.

Note: When you use Object Search from a form, the current form remains 
open. When you exit the requested object, you return to the original 
form.

To use Object Search:

1. Double-click the Direct Access field on the main menu.

OR

Select File>Object Search from any form.

2. Enter your search criteria on the Object Search Form (GUIOBJS).

You can use any or all of the Name, Description, and Type fields. You can use 
the Oracle wildcards % and _. (See "Wildcards" on page 2-76.)

3. Select the Execute Query function. A list of all matches appears.

4. Scroll to the desired name.

5. Double-click the desired name or click the Start button.
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Navigation Frame

In a client/server environment, you can use the navigation frame on the left side of 
a form to navigate within Banner. Options depend on where the cursor is currently 
located. Some options take you to other blocks and windows within the current 
form. Other options take you outside the current form to related forms. You can use 
the scroll buttons at the top of the frame if there are more options than fit in the 
frame.

See "Navigation Frame" on page 2-33 for a more detailed description of the 
navigation frame.

To select an option in the navigation frame:

Options Menu

You can use the Options menu in the menu bar to navigate within Banner. Options 
in the menu depend on where the cursor is currently located. Some options take you 
to other blocks and windows within the current form. Other options take you 
outside the current form to other related forms.

The Options menu optionally displays the form name associated with each option 
that takes you outside the current form. You can set up this option on the General 
User Preferences Maintenance Form (GUAUPRF). See "Displayed Form Names" on 
page 2-113.

SCT delivers Banner with standard navigation options. The system administrator at 
your institution can use the Options Maintenance Form (GUAOPTM) to change 
and add navigation options for your institution. Only those staff members with 
appropriate security can perform this task.

Note: Only the first 24 options defined on GUAOPTM will appear in the 
Options pull-down menu.

 

1. Move the cursor to the desired 
option. The selected option turns 
blue and is underlined.

2. Click the option. The form, 
window, or block appears.

For options that navigate to a window or 
block in the current form, read the auto 
hint for the equivalent function.

Note: You cannot use the keyboard if the 
option navigates to another form. Use 
the Options menu instead.
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To select an option in the Options menu:

 

1. Click the Options menu. 
Navigation options appear.

2. Click the desired navigation option.

1. Press the Alt key. The cursor moves 
to the menu bar.

2. Use the right arrow key to highlight 
the Options menu. Then press 
Enter.

OR

Press the letter O on your keyboard. 
Navigation options appear.

3. Use the up and down arrow keys to 
highlight the desired navigation 
option. Then press Enter.

OR

Press the underlined letter for the 
desired navigation option.

Note: The Options menu may have multiple 
menu items that begin with the same 
letter. In Internet-native Banner, you 
mst use the up and down arrow keys to 
select the desired menu item. In a 
client/server environment, you can 
press the underlined letter multiple 
times to highlight the desired item. 
Then press Enter.
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Iconic Buttons

You can use iconic buttons to access a form or window related to the record or field 
where the cursor is currently located. See "Iconic Buttons" on page 2-37 for a more 
detailed description of iconic buttons.

To select an iconic button:

Mouse

You can use the mouse to navigate to an enterable field, record, block, or window 
that is currently displayed. You can access fields in any order. You can also use the 
mouse to click iconic buttons.

Keyboard Equivalents

You can use the keyboard equivalents of Oracle functions to access a form, window, 
block, or field.

To access a form with keyboard equivalents:

1. Read the auto hint message to determine whether a redefined Oracle function 
lets you navigate to another form. (Count Query Hits, Duplicate Item, 
Duplicate Record, Exit with Value, and List are the most commonly redefined 
functions.)

2. If a redefined function is available, use Show Keys to find the keyboard 
equivalent for the redefined function.

3. Use the keyboard equivalent to access the form.

To access a window or block with keyboard equivalents:

Use the keyboard equivalents for Next Block and Previous Block to move among 
blocks. If the next/previous block is in another window, these keys take you to 
another window. 

 

1. Click the button.

2. If an Option List appears, click the 
desired option.

Otherwise, the form or window 
appears automatically.

1. Select the Next Item function until 
you reach the field that has the 
button.

2. Read the auto hint and select the 
equivalent function. (A field may 
have more than one option.)
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Note: Occasionally the Next Block function appears to move the cursor to 
another enterable field in the same block. In these cases, there are 
actually two blocks that visually appear to be one block.

To access a field with keyboard equivalents:

Use the Tab key (Next Item) and Shift+Tab keys (Previous Item) to move among 
fields. You must move in the specific order coded into the form. If a field has the 
Autoskip feature, the cursor automatically moves to the next field as soon as you 
enter the required number of characters.

QuickFlow

You can use a QuickFlow to automatically access forms that are linked in a chain. 
Activating a QuickFlow opens the first form in the chain. When you exit that form, 
the next form automatically opens.

To use a QuickFlow:

1. Select File>QuickFlow or use Direct Access to display the QuickFlow Form 
(GUAQFLW).

2. Enter the QuickFlow code in the Quickflow field.

3. Click the Start button, press Enter, or select the Next Block function. The first 
form in the QuickFlow appears.

4. Enter data on the form.

5. Exit the form. The next form in the QuickFlow appears.

6. Repeat steps 4 and 5 for each form in the QuickFlow. After you pass through 
all the forms in the QuickFlow, the GUAQFLW Form reappears.

Note: If you want to exit the QuickFlow before all the forms are accessed, select 
File>Exit QuickFlow.

If you do not have any data to enter on a form, exit the form. If the 
message DO YOU WANT TO QUIT? appears, answer Y. (The message 
depends on the form.)

7. If you are finished with the QuickFlow, exit the GUAQFLW Form.

OR

If you want to execute the QuickFlow again, return to step 3.
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Last 10 Forms in the File Pull-Down Menu

You can quickly re-access a form that was previously opened in the current session. 
The bottom of the File pull-down menu lists the last forms (up to ten) you used in 
this session. You can re-access any form in the list.

Note: The only forms that never appear in this list are the QuickFlow Form 
(GUAQFLW), Direct Access Form (GUAPARM), and Object Search 
Form (GUIOBJS).

To access a form from the File pull-down menu:

1. Access the File pull-down menu.

2. Select the form name from the list at the bottom of the pull-down menu.

Entering Information

This section tells you how to enter information on Banner forms. Recommendations 
for formatting data are included at the end of this section.

Entering Information Into Validated Fields

Many fields only accept codes from a defined List of Values (LOV). The field name 
appears in blue if the field has predefined values.

Most codes and associated descriptions in an LOV are defined on a maintenance 
form and displayed on a validation form. Some maintenance forms contain more 
than just the valid codes and their associated descriptions. For example, the Site 
Code Validation Form (STVSITE) includes address information. When an LOV is 
called from a specific field, only information that is relevant to the current form is 
displayed in the LOV.

The code/description lookup feature helps you enter information into validated 
fields. This feature is available on all fields that have a blue field name. With this 
feature you can:

• Enter a complete code or description.

• Look up a code or description based on a partial entry.

• Display the entire LOV and select a code.

If you look up a code/description or display the entire LOV, you can refine your 
search by entering search criteria or use a drill-down search.

Note: For performance reasons, this feature is unavailable on code/description 
fields on major data-entry Finance and Accounts Receivable forms. 
Instead of using the lookup feature, you can use the Search button to 
search for codes.
 SCT Banner Release 5.4 September 2002
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To enter a complete code or description in a field with a blue field name:

1. Enter the full code (for example, A005) or full description (for example, 
Registration).

2. Press Enter. The code and description appear. Depending on the field, the 
cursor may automatically skip to the next field.

To look up a code or description in a field with a blue field name:

Note: Do not use these steps if you are in query mode. Instead, execute a 
normal query. See "Querying Information" on page 2-73 for more 
information.

1. Enter as much of the code or description as you know. Use the Oracle wildcard 
% to represent any number of unspecified characters.

Example:

Enter A% to search for all codes and descriptions that start with “A”.

Note: If there is no wildcard, the search looks for an exact match.

2. Press Enter.

• If one match is found, the code and description are returned, and this 
procedure ends.

• If more than one match is found, the Search Results window appears with 
all matches. Continue with step 3.

• If no matches are found, the auto hint displays an error message. Return 
to step 1 to enter another code or description.

3. Scroll (if necessary) to the desired value in the Search Results window.

4. Double-click the value or press Enter. The window closes, and the selected 
value is returned to the code field.
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To display the entire LOV for a field with a blue field name:

 Enter a partial code. Be
sure to include the

Oracle wildcard %.

 Press Enter. This window
appears if more than one

match is found.

Scroll (if necessary) to the code
you want and double-click.

 

1. Double-click the code field.

Note: If you are on a form that was called 
from a field on another form, press the 
Ctrl key before you double-click. 
(Double-clicking by itself selects a 
value rather than displays an LOV.)

2. If more than one form or window is 
associated with the field, an Option 
List appears. Click the option that 
displays the LOV.

Otherwise, the LOV appears 
automatically.

3. Scroll (if necessary) to the desired 
value in the LOV.

4. Double-click the value. The LOV 
closes, and the selected value is 
returned to the code field.

1. Select the Next Item function until 
you reach the code field.

2. Select the List function. The LOV 
appears.

3. Scroll to the desired value in the 
LOV (if necessary).

4. Press Enter. The LOV closes, and 
the selected value is returned to the 
code field.
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To refine your search in an LOV or Search Results window:

1. Click the Find field in the LOV or Search Results window.

2. Enter your search criteria.

Use the Oracle wildcard % to represent any number of unspecified characters. 
Use the Oracle wildcard _ to represent one occurrence of an unspecified 
character. You can use both wildcards in the same search string.

Examples:

Enter A% to search for all codes and descriptions that start with “A”.
Enter _AID to search for all four-character codes that end with “AID”.

3. Click the Find button or press Enter.

Double-click this field.

This LOV appears.

Scroll (if necessary) to the code
you want and double-click.

Click this field.
Enter your search criteria.

Click this button.
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To use a drill-down search in an LOV or Search Results window:

1. In the LOV or Search Results window, press the first character of your search 
string. The list displays all codes that begin with that character.

2. Press the next character in the string. The list displays all codes that begin with 
the two characters entered.

3. Keep adding characters to reduce the list of matches.

When you see the code you want, double-click it or press Enter. The code is 
returned to the field.

OR

When you have reduced the list to one match, the code is automatically 
returned to the field.

Start with a full list of values 
for department codes.

Press the character E. The list 
shows all codes that start with E.

Press the character N. The list 
shows all codes that start with EN.

You can choose a value from the 
list or continue entering characters 
until you get a single match.
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Entering Information From Another Form

If a Search button appears next to a field, you can click the button to call another 
form, select information from the called form, and return the selected information 
to the current field.

To enter information in a field with a Search button:

 

1. Click the Search button.

2. If an Option List appears, click the 
desired option to display the form.

Otherwise, the form appears 
automatically.

3. If the form opens in query mode, 
enter your search criteria and select 
Execute Query. The form displays 
matching values.

Otherwise, the form displays 
available values.

4. Scroll (if necessary) to the desired 
value on the called form.

5. Double-click the value. The called 
form closes, and the selected value 
is returned to the field.

1. Select the Next Item function until 
you reach the field that has the 
button.

2. Read the auto hint and select the 
equivalent function. (A field may 
have more than one option.) The 
form appears.

3. If the form opens in query mode, 
enter your search criteria and select 
Execute Query. The form displays 
matching values.

Otherwise, the form displays 
available values.

4. Scroll (if necessary) to the desired 
value on the called form.

5. Select the Select function. The 
called form closes, and the selected 
value is returned to the field.
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Click this button.

Scroll (if necessary) to the value
you want. (The selected record is

highlighted.) Double-click.

If the form opens in
query mode, enter your

selection criteria.
Select Execute Query.

The form displays
matching values.
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Entering IDs

2 Using SCT 
Banner 

Many Banner forms have ID fields for persons and non-persons. For example, the 
Telephone Form (FOATELE) uses IDs to identify persons and companies. 

There are several ways to enter an ID:

• Enter a complete ID.

• Enter a complete name.

• Search by partial ID.

• Search by partial name.

• Search by SSN (U.S.), SIN (Canada), TFN (entities), or birth date.

• Use a product-specific search form.

• Search by the pattern of characters in the name (Oracle Soundex).

To enter a complete ID:

1. Enter the full ID (for example, 2314780) in the ID field.

2. Press Enter. The ID and name appear.

To enter a complete name:

1. Make sure the ID field is blank.

2. Tab to the Name field (unlabeled field next to the ID field).

3. Enter the full name.

The format is last, first, middle with a comma between each part of the name. 
Spaces between each piece are optional. Characters can be upper or lower 
case. (You get the same results whether you enter upper or lower case letters.)

Examples:

Smith, Thomas, James
Smith, Thomas (no middle name)

4. Press Enter.

• If one match is found, the ID and name are returned to the form.

• If more than one match is found, the ID and Name Extended Search 
window appears. You can select an ID (see “To select an ID from the ID and 
Name Extended Search window” on page 2-65), reduce your search (see 
“To reduce your search in the ID and Name Extended Search window” on 
page 2-65), or access a product-specific search form (see “To access a 
search form from the ID and Name Extended Search window” on page 
2-65).
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To search by partial ID:

1. Enter a partial ID in the ID field. Use the Oracle wildcard % to represent any 
number of unspecified characters.

Example:

Enter 21% to search for all IDs that start with “21”.

2. Press Enter. 

• If one match is found, the ID and name are returned to the form.

• If more than one match is found, the ID and Name Extended Search 
window appears. You can select an ID (see “To select an ID from the ID and 
Name Extended Search window” on page 2-65), reduce your search (see 
“To reduce your search in the ID and Name Extended Search window” on 
page 2-65), or access a product-specific search form (see “To access a 
search form from the ID and Name Extended Search window” on page 
2-65).

To search by partial name:

1. Make sure the ID field is blank.

2. Tab to the Name field (unlabeled field next to the ID field).

3. Enter a partial name. 

The format is last, first, middle with a comma between each part of the name. 
Spaces between each piece are optional. Characters can be upper or lower 
case. (You get the same results whether you enter upper or lower case letters.) 
Use the Oracle wildcard % to represent any number of unspecified characters.

Examples:

Enter smith,J% to search for all IDs with the last name “Smith” and first names 
that start with “J”.

Enter mag%,p% to search for all IDs with last names that start with “Mag” and 
first names that start with “P”.

Enter ,Barbara to search for all IDs with the first name “Barbara”.

4. Press Enter. 

• If one match is found, the ID and name are returned to the form.

• If more than one match is found, the ID and Name Extended Search 
window appears. You can select an ID (see “To select an ID from the ID and 
Name Extended Search window” on page 2-65), reduce your search (see 
“To reduce your search in the ID and Name Extended Search window” on 
page 2-65), or access a product-specific search form (see “To access a 
search form from the ID and Name Extended Search window” on page 
2-65).
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To select an ID from the ID and Name Extended Search window:

Use these steps when you search by ID or name and multiple matches are displayed 
on the ID and Name Extended Search window.

1. Pull down the list of matches in the Search Results field.

Note: Previous names and IDs are indented under the current name and ID.

2. Scroll to the desired name and ID.

3. Click the desired name and ID. The ID and name are returned to the form.

To reduce your search in the ID and Name Extended Search window:

Use these steps when you search by ID or name and multiple matches are displayed 
on the ID and Name Extended Search window.

1. Select the Person, Non-Person, or Both radio button in the Reduce Search By 
block to identify the kind of IDs you want to search. The field next to the 
Search Results field shows the number of matches.

2. Enter your search criteria in the fields in the Reduce Search By block.

3. Click the Search button or select Execute Query. The field next to the Search 
Results field shows the number of matches. 

4. (Optional) Repeat steps 2 and 3 to further reduce your search.

To access a search form from the ID and Name Extended Search window:

Use these steps when you search by ID or name and multiple matches are displayed 
on the ID and Name Extended Search window.

1. Click the Person Search Detail button or the Non-Person Search Detail button. 
The associated search form appears with IDs that match your original search 
criteria. Your original search criteria appear at the top of the form.

Example:

If Smith, J% is your original search criteria and you select the Person Search 
Detail button, the search form shows all person IDs with the last name “Smith” 
and first names that start with “J.”

2. To select an ID, skip to step 8.

OR

To reduce your search further, go to step 3.

3. Select the Enter Query function. A dialog box appears.
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4. To extend the current search, select the Extend Your Current Query button. 
Information on the form is cleared. (Your original search criteria remain at the 
top of the form.)

OR

To discard the current search and start over, click the Start a New Query 
button. Information on the form is cleared.

5. Enter your search criteria in any fields on the form. 

If you enter a partial field value as a search criteria, use Oracle wildcards. Use 
the symbol % to represent any number of unspecified characters. Use the 
symbol _ to represent one occurrence of an unspecified character. You can use 
both wildcards in the same search string.

6. Select the Execute Query function. The form shows all IDs with matching 
information. 

7. Scroll to the desired ID.

8. Double-click the desired ID. The ID and name are returned to the calling form.

To search by SSN (U.S.), SIN (Canada), TFN (entities) or birth date:

ID fields on some forms allow you to go to the SSN/SIN/TFN Alternate ID Search 
Form (GUIALTI) and search for an ID by SSN, SIN, TFN or birth date. 

1. Click the Search button next to the ID field on a form. An Option List appears.

2. Select the alternate ID search option. The SSN/SIN/TFN Alternate ID Search 
Form (GUIALTI) opens in query mode.

Note: Other available search options depend on the specific form and are not 
described here.

3. Enter your search criteria in any fields on the search form.

If you enter a partial field value, use Oracle wildcards. Use the symbol % to 
represent any number of unspecified characters. Use the symbol _ to represent 
one occurrence of an unspecified character. You can use both wildcards in the 
same search string.

Examples:

Enter 148296890 in the SSN/SIN/TFN field to search for IDs with that SSN.

Enter 06-JUN-1982 in the Birthdate field to search for IDs with that birth date.

4. Verify the Case Sensitive Query radio buttons. Change if necessary.

5. Select the Execute Query function. The form shows all IDs with matching 
information.
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6. Scroll to the desired ID.

7. Double-click the desired ID. The ID and name are returned to the calling form.

To use a product-specific search form:

ID fields on some forms allow you to go to a product-specific search form and search 
for a person or non-person by ID or name.

1. Click the Search button next to the ID field on a form. An Option List appears.

2. Select the option for the person or non-person search form you want to access. 
The selected form opens in query mode.

Note: Other available search options depend on the specific form and are not 
described here.

3. Enter your search criteria in any fields on the search form. 

If you enter a partial field value, use Oracle wildcards. Use the symbol % to 
represent any number of unspecified characters. Use the symbol _ to represent 
one occurrence of an unspecified character. You can use both wildcards in the 
same search string.

Examples:

Enter Carnegie in the Last Name field to search for all IDs with the last name 
“Carnegie”.

Enter Chris% in the First Name field to search for all IDs with first names that 
start with “Chris”.

4. Select the Execute Query function. The form shows all IDs with matching 
information.

5. Scroll to the desired ID.

6. Double-click the desired ID. The ID and name are returned to the calling form.
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To search by the pattern of characters in the name (Oracle Soundex):

An added option on most search forms is the Oracle Soundex search feature. You 
can search for an ID by entering a pattern of characters in the ID’s name. This 
feature is useful if you aren’t sure how to spell a name. As long as the first letter of 
your search string is correct, you can retrieve names with a similar pattern of 
characters.

1. Click the Search button next to the ID field on a form. An Option List appears.

2. Select the option for the search form you want to access. The selected form 
opens in query mode.

Note: Other available search options depend on the specific form and are not 
described here.

3. Select the Cancel Query function.

4. Select the Search Using “Sounds Like” option from the Option menu (or 
navigation frame), or select the Next Block function. The Soundex Search 
window appears.

5. Enter a string of characters for the last name you want to find.

You can use upper, lower, or mixed case. You can enter as much or as little of 
the name as you know. As long as the first letter is correct, the search will 
retrieve names with a similar pattern of characters.

6. (Optional) Enter a string of characters for the first name you want to find.

7. Select the Execute Query function. The search form shows all IDs that have a 
matching pattern of characters.

8. Scroll to the desired ID.

9. Double-click the desired ID. The ID and name are returned to the calling form.
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2 Using SCT 
Banner 

Inserting New Records

Many forms contain multiple records that appear as rows. For example, an ID might 
have multiple address records (billing, home, and emergency contact).

You must be careful when you insert a new record:

• Once you start entering information for a new record, you must enter all 
required fields. If you change your mind, you must use Clear Record or Remove 
Record to exit. You cannot click out of a required field.

• Sometimes you must save or delete a record before you can continue. The auto 
hint identifies these situations.

To insert a new record:

1. Place your cursor on an existing record.

2. Select the Insert Record function. A new blank record is inserted in the list of 
existing records.

3. Enter information for the new record. Make sure you enter all required fields.

4. Select the Save function.

Data Format Recommendations

To ensure consistent information throughout your Banner System, data should be 
entered in a standard way. SCT recommends the following standards.

Identification (ID) Numbers

Persons Enter an identification number of your choice, or use the 
identification number generated by the system on any 
Identification Form (xxxIDEN).

Non-persons Use the system-generated identification number.
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Names

Addresses

Upper/lower case Use conventional upper- and lower-case letters.

Last names Do not enter spaces within prefixed last names. 
Examples: MacArthur, O’Connor, VanHusen, deBolt, DuShen

Do not enter spaces within hyphenated last names. 
Examples: Smith-Jones, Cochram-Ashley

First initials with
middle names

Enter a period and one space between the first initial and 
middle name.
Example: R. Maureen Smith

Prefixes/suffixes Use a period after a prefix or suffix, where applicable.
Examples: Miss, Mrs., Mr., Rev., Jr., II

Pound sign If your institution uses the Banner Letter Generation module, 
a pound sign (#) in addresses may affect letter processing. The 
pound sign is a formatting command. Refer to the SCT Banner 
General Technical Reference Manual for details.

County Use the county codes defined on the County Code Validation 
Form (STVCNTY).

State and province Use the codes defined on the State/Province Code Validation 
Form (STVSTAT).

ZIP/postal code Use the standard format for the country in the address. Use 
the codes defined on the ZIP/Postal Code Validation Form 
(GTVZIPC).

Nation Enter a nation code only if you want to include the nation 
when the address is printed. Use the codes defined on the 
Nation Code Validation Form (STVNATN).
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Letter Generation

Dates 

A setting on the Installation Control Form (GUAINST) controls how you enter 
dates:

Banner determines which parts of a date entry are the month, day, and year, and 
automatically converts and stores the date in the DD-MON-YYYY format. Year 
numbers 00 through 49 are converted to 2000 through 2049. Year numbers 50 and 
above default to 1950 through 1999. You can override the century default.

Follow these general recommendations when you enter dates:

• Always enter two digits for the day and month. For example, enter 01 for 
January, not 1.

• If you enter only part of the date, the rest of the current date is the default.

• You can enter a date without separators (no spaces), or you can use a dash (-) 
or slash (/) as separators.

Dates in Job Submission

Use the DD-MON-YYYY or DD-MON-YY format to enter date parameters for reports 
and processes run with the Process Submission Control Form (GJAPCTL).

Dates in Reports and Process Output

Some, but not all, reports include the century with the year in their output.

Dates in Query Mode

Specify all four digits for a year when you query on a date field. For example, enter 
26-JUN-2002, not 26-JUN-02. If you omit the century, zeros are entered for the 
century. In this example, if you enter 26-JUN-02, Banner expands the date to 
26-JUNE-0002, not 26-JUN-2002. 

Paragraph Letter Generation uses the pound sign (#) and period (.) to set 
the output mode back to normal. If you want a # or period to 
be text in your output, then precede it with a backslash.

If this format is selected: Enter February 5, 2002 like this:

MDY Month, Day, Year 02/05/02, 02-05-02, or 020502

DMY Day, Month, Year 05/02/02, 05-02-02, or 050202

YMD Year, Month, Day 02/02/05, 02-02-05, or 020205
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Querying Information

Querying is the process of looking to see what information is already entered in the 
Banner database. You can use inquiry forms, query forms, and most application 
forms to perform queries.

Some forms automatically open in query mode, usually because a large number of 
records would have to be retrieved. When a form opens in query mode, Enter Query 
appears in the status line. You can immediately specify search criteria to narrow the 
search. If a form does not open in query mode you must put the form into query 
mode before you can enter search criteria.

Query Functions

Use the following functions to perform queries:

Enter Puts the form into query mode so you can enter search criteria to see 
what information is already in the database. Enter Query appears in 
the status line.

Execute Searches the database and displays the first set of records that match 
your search criteria. This function is enabled only if you are in query 
mode.

Last 
Criteria

Enters the criteria from your last search. You can change any of the 
criteria. This function is enabled only if you are in query mode.

Exit or
Cancel 

Cancels the query and takes the form out of query mode.

Note: If you aren’t in query mode, the Cancel Query button on 
the toolbar exits you from the form.

Count 
Query Hits

Counts the number of records that match the search criteria and 
displays that number in the auto hint.

Fetch Next 
Set

Replaces the current set of displayed records with the next set of 
records if more records match the search criteria than fit in the 
window. This function is enabled only if you are in query mode.
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To query information:

1. Access the form you want to query.

2. If the form opens in query mode (Enter Query is in the status line), go directly 
to step 3. 

If the form does not open in query mode (Enter Query is not in the status line), 
select the Enter Query function.

3. Enter the search criteria. 

You can query information in any field that you can access. You can use the 
Oracle wildcards % and _. Capitalization matters. Data is matched against the 
search criteria exactly as you enter them.

4. Select the Execute Query function. The form displays all records that match 
the search criteria.

Enter the search criteria.

The form displays all
matching records.

Make sure the form
is in query mode.

Select Execute Query.
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To change your search criteria and re-query:

Use these steps after you query information and you want to re-query with different 
search criteria.

1. With the original matches displayed, select the Enter Query function. 
Matching records from the previous query disappear.

2. Select the Enter Query function a second time. The original search criteria 
appear. 

3. Revise your search criteria.

4. Select the Execute Query function. The form displays all records that match 
the revised search criteria.

To query a checked checkbox:

1. Select the Enter Query function.

2. Select (check) the checkbox.

3. (Optional) Enter additional search criteria.

4. Select the Execute Query function. The form displays records that have 
matching information, including a checked checkbox.

To count queries:

Use these steps to determine how many records match your query criteria before 
you execute the query.

1. Access the form you want to query.

2. If the form opens in query mode (Enter Query is in the status line), go directly 
to step 3. 

If the form does not open in query mode (Enter Query is not in the status line), 
select the Enter Query function.

3. Enter the search criteria. 

You can query information in any field that you can access. You can use the 
Oracle wildcards % and _. Capitalization matters. Data is matched against the 
search criteria exactly as you enter them.

4. Select the Count Query Hits function. The auto hint shows the number of 
matches.

Note: On some forms the Count Query Hits function is redefined to a special 
function. In these cases, Count Query Hits may not count the number of 
records that match your query criteria.
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Wildcards

You can use the Oracle wildcards % and _ in the search criteria:

• The character % represents any number of unspecified characters. 

• The character _ represents one occurrence of an unspecified character. 

The following examples illustrate the use of wildcards:

With experience, it becomes easier to narrow your queries to get the results you 
want.

Extended Queries

With extended queries, you can use SQL*Plus operators to enter more specific 
query criteria. 

To perform an extended query:

1. Access the form you want to query.

2. If the form opens in query mode (Enter Query is in the status line), go directly 
to step 3. 

If the form does not open in query mode (Enter Query is not in the status line), 
select the Enter Query function.

3. Move to the field where you want to use extended query.

4. Enter a colon followed by an identifying character such as A. If you are using 
extended query in more than one field, enter a different character in each field 
(for example, :B, :C, and :D).

5. (Optional) Enter additional search criteria.

6. Select the Execute Query function. The Query/Where window opens.

7. Enter the search criteria beginning with a colon, followed by the identifying 
character, the appropriate SQL*Plus query operators, and values to match.

Example: :A>’15-SEP-99’

To get these results: Enter this criteria:

All entries that contain “ma” %ma%

All entries that begin with “ma” ma%

All entries that have “ma” as the last two characters %ma

All entries that have “m” as the second character _m%
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Note: Due to Oracle limitations, the maximum number of search characters is 
200.

8. Click the OK button. The form reappears with the results of the query. 

Note: The Search button in the Query/Where window controls the Oracle 
Search and Replace function, not the Execute Query function.

Enter :A as the search criteria.

Select Execute Query.

This window appears. Enter :A
followed by the appropriate

SQL*Plus query operators and
the values to match.

Click this button.

The form displays
all matching

records.
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Date Queries

Date queries require special care.

Centuries in the Year

You must specify all four digits for a year when you query on a date field. For 
example, enter 26-JUN-2002, not 26-JUN-02. If you omit the century, zeros are 
entered for the century. In this example, if you enter 26-JUN-02, Banner expands the 
date to 26-JUNE-0002, not 26-JUN-2002.

Fiscal year queries and grant year queries are exceptions:

• For a specific fiscal year or grant year, you must enter two digits for the year, not 
four digits. A century of 20 is automatically used for years 00 through 49. A 
century of 19 is automatically used for years 50 through 99.

• For a range of fiscal years or grant years, use an extended query. See "Extended 
Queries" on page 2-75.

Dates and Time Stamps

Banner stores most dates with a time stamp. You don’t see the time stamp, but it’s 
part of the date record and can affect the results of a query.

When you include a date in your query criteria, Banner often adds the time 00:00:00 
to the query criteria. You probably won’t get any matches with this timestamp, 
resulting in the message Query caused no records to be retrieved. Re-enter. To get 
the results you want, use one of these methods to enter the search criteria:

• Use a relational operator with an earlier or later date. For example, to find 
records dated 26-JUN-2002, enter >25-JUN-2002 and < 27-JUN-2002. The query 
results will include all records dated after June 25 and before June 27.

• Use an extended query. In the Query/Where window, use a two-digit year (for 
example, 02 rather than 2002). For more information on extended query, see 
"Extended Queries" on page 2-75.

Viewing Job Submission Output

You can view Job Submission output online with the Saved Output Review Form 
(GJIREVO) regardless of the file extension:

• The log file can be viewed for the Letter Extract Process (GLBLSEL).

• The log, lis, and doc (for mail merge) files can be viewed for the Letter 
Generation Print Report (GLRLETR). These files can be written to the 
database, and can be displayed or saved to your local desktop machine.

This feature works with Pro*C programs only.
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Viewing Output in Internet-Native Banner

With Internet-native Banner, you can display output in a browser window.

To set up online viewing in Internet-native Banner:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Directory Options button at the top of the form. The Directory 
Options window appears.

3. Scroll to the record where Description is Enter the name of your Web Output URL.

4. In the User Value field, enter the URL that contains the logic used to pull 
GJIREVO output from the database and display it in a browser window.

Note: In Internet-native Banner, the online Job Submission output and data 
extract features both use this URL 

5. Click the OK button.

To view, save, and print online output in Internet-native Banner:

1. Use the Process Submission Control Form (GJAPCTL) to run the report or 
process as usual. Enter DATABASE in the Printer field.

2. Access the Saved Output Review Form (GJIREVO). The form shows the 
Process and Number of the report or process just run.

3. Double-click the File Name field and select the log or list file you want to 
display. The output is displayed.

4. Select Show Documents (Save and Print File) from the Options menu. A dialog 
box asks if you want to continue.

5. Click the Yes button. Output is displayed in a browser window.

6. (Optional) To save the output, use the browser File>Save As option.

7. (Optional) To print the output:

(a) If you have not already done so, use the browser File>Save As option to save 
the output.

(b) Open the saved output.

(c) Use the File>Print option to print the output.
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Viewing Output in a Client/Server Environment

To set up online viewing in a client/server environment:

1. Access the Job Submission Profile Maintenance Form (GJAJPRF).

2. For the DEFAULT_PRINTER component, enter the ID of the printer used to 
print Job Submission output in the Value field.

3. For the LOCAL_DIRECTORY component, enter the local directory where 
GJIREVO output is stored in the Value field.

To view, save, and print online output in a client/server environment:

1. Use the Process Submission Control Form (GJAPCTL) to run the report or 
process as usual. Enter DATABASE in the Printer field.

2. Access the Saved Output Review Form (GJIREVO). The form shows the 
Process and Number of the report or process just run.

3. Double-click the File Name field and select the log or list file you want to 
display. The output is displayed.

4. (Optional) To save the output to your local directory and print in a Windows 
environment, select the Save and Print File option. A series of dialog boxes asks 
you to choose a printer and optionally set up a default printer.

OR

(Optional) To save the output to your local directory and print in a Macintosh 
environment, select the Save to File option. Then print from your desktop.

5. (Optional) To save the output without printing, select Save to File option.

Extracting Banner Data to a Spreadsheet

You can extract data from a Banner form to a spreadsheet. You can extract detail 
data from the current block with or without data from the key block. Once Banner 
data is in a spreadsheet, you can easily graph and report the data.

Availability of the Extract Feature

SCT delivers the extract feature on all validation forms. SCT also supports the 
extract feature on a limited number of rule, application, and inquiry forms where 
the feature has been tested. This feature has been tested on the following Finance 
and common forms:
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Your system administrator can use the Object Maintenance Form (GUAOBJS) to 
enable the extract feature on any form where the extract has been tested.

Extract results are unpredictable on forms that have not been tested with this 
feature. If you want to extract data on an untested form, your system administrator 
can consider enabling the extract feature on GUAOBJS. SCT does not support this 
feature on untested forms. SCT will, however, continue to test more forms and 
expand support with future releases.

You can tell that the extract feature is enabled on a specific form if one or both of 
the following options is enabled in the Help pull-down menu for the form:

• Extract Data with Key extracts details in the current block with key data.

• Extract Data No Key extracts details in the current block without key data.

A field on GUAOBJS determines whether one, both, or neither of these extract 
options is available for a form.

Extracting Data in Internet-Native Banner

In Internet-native Banner, you can save the data to a file with a .csv extension or you 
can display it as text in a new browser window, depending on what is set up in the 
Directory Options window on the General User Preferences Maintenance Form 
(GUAUPRF).

To set up data extract for Internet-native Banner:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Directory Options button at the top of the form. The Directory 
Options window appears.

Extract details with or without key data: Extract details only:

FGITBAL FEREDIC
FIASPND FFAFDEL
FOATEXT FFASYSC
FRIBUDT FOA1099
FRIBUTG FOASYSC
FRIEVNG FRIBUDG
FRIEVNP FRIBUDP
FRIGSUM FRIGRNT
SOAHOLD FRIPROP

FTMACCI
FTMACCT
FTMACTV
FTMCOAS
FTMLOCN
SLABQRY
SLQEVNT
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3. Scroll to the record where Description is Internet Native data extract format: FILE 
(.csv) or TEXT.

4. If you want your extracted data to be placed into a file in comma separated 
value format (with a .csv extension), enter FILE in the User Value field.

OR

If you want your extracted data to be displayed in a separate browser window, 
enter TEXT. The information is display-only, but you can save it in a variety of 
formats.

5. Scroll to the record where Description is Enter the name of your Web Output URL.

6. In the User Value field, enter the URL that contains the logic used to pull 
extracted data from the database and display it in a browser window.

Note: In Internet-native Banner, the online Job Submission output and data 
extract features both use this URL 

7. Click the OK button.

To extract data in Internet-native Banner:

1. Access the Banner form.

2. If applicable, display the desired records on the form.

3. Select one of the following options from the Help pull-down menu:

• Extract Data with Key (to extract key data and data in the current block

• Extract Data No Key (to extract data in the current block only)

Extracted data is displayed in a browser window.

4. For Internet Explorer, use the browser File>Save As option to save the 
extracted data to a local directory as a .txt file. Then rename the file as a .csv 
file.

OR

For Netscsape, use the browser File>Save As option to save the extracted data 
to a local directory as a .csv file.

Extracting Data in a Client/Server Environment

To identify a user-defined directory location for extract files:

Your system administrator identifies the directory where extract files are located. 
You can override your institution’s default directory and identify your own directory 
location for extract files. 
September 2002 SCT Banner Release 5.4
Confidential Using SCT Banner Finance 2-81



Chapter 2 Using SCT Banner
1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Directory Options button at the top of the form. The Directory 
Options window appears.

3. Make sure your cursor is in the first record (Description is Enter the location for 
where to write the data extract file.).

4. Enter the name of the directory for storing extract files in the User Value field.

Caution: Choose your directory location carefully. For security reasons, we 
recommend that you don’t use a central, shared directory.

5. Click the OK button.

Note: If you later want to use the Default Value, you must delete the record. 
Simply erasing the User Value does not work.

To extract data in a client/server environment:

1. Access the Banner form.

2. If applicable, display the desired records on the form.

3. Select one of the following options from the Help pull-down menu:

• Extract Data with Key (to extract key data and data in the current block

• Extract Data No Key (to extract data in the current block only)

Data is extracted, and a dialog box identifies the name and location of the 
extract file.

4. Go to the directory where the extract file is stored and open it.
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Using the Calendar

There are three ways to display the calendar:

• Double-click any date field. If the date field has a value, the calendar highlights 
that date. If the date field is empty, the calendar highlights the current date. You 
can double-click a date on the calendar to return it to the calling form.

• Use Direct Access to display the Calendar Form (GUACALN). When accessed 
this way, the calendar works independently of any form or field. You cannot 
select a date and return it to a form.

• Select Help>Calendar. When accessed this way, the calendar works 
independently of any form or field. You cannot select a date and return it to a 
form.

Double-click this field.

The calendar appears.

Double-click any date on the calendar to
return it to the Date field on the form.
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Using the Calculator

There are three ways to display the calculator:

• Double-click any numeric field. If the numeric field has a value, the calculator 
shows that value. You can use the mouse, number keys on the keyboard, or the 
numeric keypad (if the NumLock is enabled) to make calculations. When 
you’re done, click the OK button to return the calculated value to the calling 
form.

• Use Direct Access to display the Calculator Form (GUACALC). When accessed 
this way, the calculator works independently of any form or field. You cannot 
return a calculation to a form.

• Select Help>Calculator. When accessed this way, the calculator works 
independently of any form or field. You cannot return a calculation to a form.

Using Help

Banner has several kinds of help that can give you immediate online assistance:

• Online help. This is the newer version of online information for Banner forms, 
windows, blocks, and fields. It is currently available for selected forms only.

• Dynamic Help. This is the traditional help for Banner forms, blocks, and fields. 
SCT Banner Dynamic Help is gradually being replaced by online help.

• SCT Documentation Bookshelf. This tool lets you access Banner documents 
directly from your computer. These electronic documents look the same as the 
hard copy versions, regardless of the computer you are using. 

• Help (Item Properties). This list shows all the properties of the field where the 
cursor is currently located.

Double-click this field.

The calculator appears.

Make your calculations.

Click this button to return the calculated 
value to the numeric field on the form.
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• Show Keys. This list shows the Oracle functions and associated keystrokes 
available in your environment for the field, window, and form where the cursor 
is currently located.

• Auto hint. This hint at the bottom of the form briefly describes the field where 
the cursor is located. Error and processing messages also appear here.

Online Help

The Online Help System is the newer version of online information for Banner 
forms, windows, blocks, and fields. You can easily access online help for the current 
form or another form in the same product.

Online help is currently available for selected forms only. If available, the Online 
Help option is enabled in the Help pull-down menu. 

Online help is installed with the normal upgrade of Banner. You must tell Banner 
where to find the online help files.

To identify the location of online help files:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Directory Options button at the top of the form. The Directory 
Options window appears.

3. If you plan to run Banner in an Internet-native environment, tab to the second 
record and enter the User Value. This is the URL that identifies the location of 
the online help files used when Banner runs through a Web browser.

4. If you plan to run Banner in a client/server environment, tab to the third 
record and enter the User Value. This is the directory location of the online 
help files used when Banner is run in a client/server environment.

5. Click the OK button.

Note: If you later want to use a Default Value, you must delete the record. 
Simply erasing the User Value does not work.
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To display online help in an Internet-native environment:

To display online help in a client/server environment:

You can use the buttons at the top of each help topic to display other help topics:

 

1. Click the Online Help button in the 
toolbar. 

2. For Internet Explorer, you are 
prompted about downloading the 
help file. Respond to the prompt. A 
list of online help topics for the 
form appears.

OR

For Netscape, the first time you 
download you are prompted for an 
application to launch the 
download. Find and execute 
winhlp32.exe. A list of online help 
topics for the form appears.

3. Double-click the desired topic.

1. Select Help>Online Help.

2. For Internet Explorer, you are 
prompted about downloading the 
help file. Respond to the prompt. A 
list of online help topics for the 
form appears.

OR

For Netscape, the first time you 
download you are prompted for an 
application to launch the 
download. Find and execute 
winhlp32.exe. A list of online help 
topics for the form appears.

3. Scroll to the desired topic.

4. Press Enter.

 

1. Place the cursor in an enterable 
field.

2. Click the Online Help button in the 
toolbar. Field-level help appears.

1. Place the cursor in an enterable 
field.

2. Select Help>Online Help. Field-
level help appears.

Overview of the current form

List of procedures

List of windows, blocks, and fields
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To display online help for another form in the current product:

1. Access online help.

2. Click the Contents button at the top of the topic. A Table of Contents appears.

3. Double-click the form you want to access. The Table of Contents expands.

4. Double-click the topic you want to access. The selected topic appears. Use the 
blue buttons at the top of the topic to navigate through the form’s online help.

Dynamic Help

Dynamic Help is the traditional help for Banner forms, blocks, and fields. Dynamic 
Help is gradually being replaced by online help.

Banner provides two kinds of Dynamic Help:

• SCT Banner Dynamic Help. This help is delivered and updated each time the 
system is upgraded. You can change this help text, but each system upgrade 
overwrites your changes. This type of Dynamic Help is gradually being replaced 
by online help.

• Local Dynamic Help. This help is completely written and maintained by your 
institution. System upgrades do not affect this help text. This is the default when 
you access Dynamic Help.

Dynamic Help is displayed on the Help Form (GUAHELP). You can access 
GUAHELP in query mode or edit mode.

You can use the main window of GUAHELP to identify the help text you want to 
access. A checkbox tells you if the requested item has help text.

When you first access the main window, the selection criteria indicate Local 
Dynamic Help for the field where the cursor is located. Banner internal item names 
identify the current form, block, and field.

You can override the defaults and access help text for another form, block, or field. 
For SCT Banner Dynamic Help, you must use internal block and field names. For 
Local Dynamic Help, you can create block and field names that make sense to your 

Identify the specific item whose 
Dynamic Help you are accessing.

This checkbox indicates whether the 
requested Dynamic Help exists.

Choose Dynamic Help
for a form, block, or field.

Choose SCT Banner Dynamic
Help or Local Dynamic Help.
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institution. (Banner does not define the names.) Once you create a name, you must 
always use that name to access Local Dynamic Help for the item.

To access Dynamic Help in query mode:

To access Dynamic Help in edit mode:

1. Select Help>Dynamic Help Edit. The Help Form (GUAHELP) appears. The 
default selection criteria indicate Local Dynamic Help for the current field.

2. Verify the default selection criteria. Change if necessary.

3. Select the Edit button or the Next Block function. The Help Text window shows 
help text for the requested item.

To override the defaults and access Dynamic Help for another item:

1. Access Dynamic Help in either query mode or edit mode. The default selection 
criteria on the Help Form (GUAHELP) indicate Local Dynamic Help for the 
current field.

2. To access help text for another form, choose the Form radio button and enter 
the form name.

OR

To access help text for another block, choose the Block radio button and enter 
the form and block names.

OR

To access help text for another field, choose the Field radio button and enter 
the form, block, and field names.

3. Select the radio button for the type of Dynamic Help you want to access (SCT 
Banner Dynamic Help or Local Dynamic Help).

 

1. Press Shift and double-click a field. 
The Help Form (GUAHELP) 
appears. The default selection 
criteria indicate Local Dynamic 
Help for the field you clicked.

2. Verify the default selection criteria. 
Change if necessary.

3. Click the Display button. The Help 
Text window shows help text for the 
requested item.

1. Select Help>Dynamic Help Query. 
The Help Form (GUAHELP) 
appears. The default selection 
criteria indicate Local Dynamic 
Help for the current field.

2. Verify the default selection criteria. 
Change if necessary.

3. Select the Next Block function. The 
Help Text window shows help text 
for the requested item.
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4. Select the Display button (query mode), Edit button (edit mode), or Next 
Block function. The Help Text window shows help text for the requested item.

To choose a block or field name from an LOV:

Use these steps if you don’t know the block or field name of the Dynamic Help you 
want to display. You can display an LOV that lists all the blocks or fields on the form 
that have Dynamic Help. 

If you display SCT Banner Dynamic Help, the LOV shows internal item names. If 
you display Local Dynamic Help, the LOV shows the names you assigned.

To enter or update Dynamic Help:

1. Select Help> Dynamic Help Edit. The Help Form (GUAHELP) appears. The 
default selection criteria indicate Local Dynamic Help for the current field.

2. Verify the default selection criteria. Change if necessary. 

3. Select the Edit button or the Next Block function. The Help Text window shows 
help text for the requested item.

 

1. Access the Help Form 
(GUAHELP).

2. Click the SCT Banner or Local radio 
button on the main window.

3. Verify the form name. Change if 
necessary.

4. For block names, click the Search 
button on the Block field. An LOV 
appears.

OR

For field names, verify the block 
name. Then click the Search button 
on the Field field. An LOV appears.

5. Scroll to the desired name.

6. Double-click the name. The 
selected name is returned to 
GUAHELP.

1. Access the Help Form 
(GUAHELP).

2. Select the SCT Banner or Local 
radio button on the main window.

3. Verify the form name. Change if 
necessary.

4. For block names, select the Next 
Item function until you reach the 
Block field.

OR

For field names, verify the block 
name. Then select the Next Item 
function until you reach the Field 
field.

5. Select the List function. An LOV 
appears.

6. Scroll to the desired name.

7. Press Enter. The selected name is 
returned to GUAHELP.
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4. Enter your changes in the Help Text window. 

You can use the Editor to modify text. See "Using the Editor" on page 2-94. You 
can search for a specific string of characters or replace a string of characters 
with another string (instructions follow).

5. Select the OK button in the Help Text window. The GUAHELP main window 
appears.

6. Select the Save function. A dialog box appears.

7. Select the OK button or press Enter.

To search for a string of characters:

1. Access Dynamic Help in query mode or in edit mode. The default selection 
criteria on the Help Form (GUAHELP) indicate Local Dynamic Help for the 
current field.

2. Verify the default selection criteria. Change if necessary.

3. Select the Edit button (edit mode), Display button (query mode), or Next 
block function. The Help Text window appears.

4. Select the Search button. The Search/Replace window appears.

5. Enter the search string in the Search for field.

6. Select the Search button. The Help Text window displays the area that contains 
the first occurrence of the search string.

7. (Optional) Continue selecting the Search button to find the next occurrence of 
the string.

Verify the selection criteria. 
Change if necessary.

Click this button.

This window 
appears. Enter your 
changes here.

Click this button.
Save.
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To replace a string of characters:

1. Select Help> Dynamic Help Edit. The Help Form (GUAHELP) appears. The 
default selection criteria indicate Local Dynamic Help for the current field.

Note: You must access GUAHELP in edit mode.

2. Verify the default selection criteria. Change if necessary.

3. Select the Edit button or the Next block function. The Help Text window 
appears.

4. Select the Search button. The Search/Replace window appears.

5. Enter the search string in the Search for field.

6. Enter the replacement string in the Replace with field.

7. To replace the next occurrence of the string, select the Replace button. You 
can continue clicking the Replace button to replace each occurrence.

OR

To replace all occurrences of the string, select the Replace All button.

8. Respond to the dialog boxes (if displayed) to continue the search.

9. Select the Cancel button on the Search/Replace window. 

10. Select the OK button on the Help Text window. 

11. Select the Save function on the main window. A dialog box appears. 

12. Select the OK button or press Enter.

SCT Documentation Bookshelf

The Bookshelf cannot be 
displayed in Internet-native 
Banner.

The SCT Documentation Bookshelf is an easy way to access Banner documents 
directly from your computer. The Bookshelf includes both user and technical 
documentation. Documents in the Bookshelf appear in PDF (portable document 
format). They look the same as the hard copy versions, regardless of the computer 
you are using. You can print any document locally.

The Bookshelf can be downloaded to a central location at your institution, making 
it available for use by authorized users. Your system administrator can use 
Implementing SCT Documentation Bookshelf to set up the Bookshelf.

In addition to the system setups, you must install Adobe Acrobat Reader with Search 
on your computer. This software is freely available from Adobe and lets you open, 
read, print, and search the PDF files in the Bookshelf.
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To open the SCT Documentation Bookshelf:

To access a specific manual and chapter:

1. Open the Bookshelf.

2. In the left pane, click the bookmark in front of the product you want to access. 
The bookmark expands to show the product’s documents.

3. If necessary, expand bookmarks in the left pane until you see the document or 
chapter you want to display.

4. Click the name of the document or chapter you want to display. The selected 
document or chapter appears in the right pane.

To set up your search preferences:

You can search for information in one or more documents. You must set up your 
preferences before you can search the Bookshelf. You only need to enter these 
setups once.

1. Open the Bookshelf.

2. Select File>Preferences>Search to display the Acrobat Search Preferences 
window.

3. Set up your preferences.

4. Click the OK button.

To attach indexes for the documents you want to search:

Before you can search a document, you must attach its index. You only need to 
attach a specific index once.

1. Determine where the index files are located (file extension .pdx). They are in 
the folder named _index5x. This folder is located in the same folder as the 
Bookshelf files. Check with your data center personnel, if necessary.

2. Open the Bookshelf.

3. Select Search Indexes in the left pane. The Index Selection window appears 
with a list of the currently attached indexes.

4. Click the Add button. The Add Index window appears.

 

Click the Bookshelf button on the 
toolbar.

Select Help>SCT Banner Bookshelf.
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5. Select the index you want to attach. You may have to change directories to find 
it.

6. Click the Open button. The selected index is added to the Index Selection 
window.

7. Repeat steps 4 through 6 for each index you want to add.

8. Click the OK button in the Index Selection window.

To search for information:

Note: Adobe Acrobat Reader with Search must be loaded on your computer. 

1. Open the Bookshelf.

2. Click the Search button  in the Acrobat toolbar, or select Search Query in 
the left pane. The Adobe Acrobat Search window opens.

3. Enter the text you want to find.

4. Click the Indexes button. The Index Selection window appears.

5. Select the manuals you want to search.

6. Click the OK button in the Index Selection window. The Index Selection 
window closes.

7. Click the Search button in the Adobe Acrobat Search window.

If one file contains the requested text, the file appears. This procedure ends.

OR

If more than one file contains the requested text, the Search Results window 
appears with a list of the files that contain the requested text. Continue with 
step 8.

8. Select the file you want to display. 

9. Click the View button. The selected file appears.

Help (Item Properties)

Help (Item Properties) lists all the properties of the current field. For example, you 
can find its internal database name, whether it is queryable, whether it is required, 
type of data (character or numeric), maximum length, and minimum and 
maximum values. See your Oracle documentation for information on each item 
property.
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To display Help (Item Properties) for a field:

1. Place the cursor in the field

2. Select the Help (Item Properties) function.

Show Keys

Show Keys lists the Oracle functions and associated keystrokes available in your 
environment for the current field, window, and form. Specific keystrokes for a 
function depend on your environment.

To display Show Keys:

Select the Show Keys function.

Auto Hint

The auto hint at the bottom of the form can contain the following information for 
the field where the cursor is located:

• Brief field description

• Error and processing messages

• Keyboard equivalents (if you can access other blocks, windows, or forms from 
the field)

Using the Editor

The editor is a tool that helps you enter, update, and view information in a data field. 
For example, you can use the editor to enter, update, and view Dynamic Help text 
on the Help Form (GUAHELP).

Some data fields are actually longer than they appear on the form. With the editor, 
you can expand a data field to display a larger, freeform window where it is easier to 
read or enter more data. The size of the window depends on the defined length of 
the field.

To expand a data field:

1. Place the cursor in the field you want to expand.

2. Select the Edit function. A freeform window appears.

Note: Some data fields have a Comment button that you can click to open the 
freeform window. 
 SCT Banner Release 5.4 September 2002
2-94 Using SCT Banner Finance Confidential



Chapter 2 Using SCT Banner
To select text:

To insert text:

To replace text:

1. Select the text you want to replace.

2. Enter the new text. The new text replaces the existing text.

To copy text and save it on the clipboard:

1. Select the text you want to copy.

2. Select the Copy function. The text remains in its current location and is copied 
into an invisible clipboard.

To cut text and save it on the clipboard:

1. Select the text you want to cut.

2. Select the Cut function. The text is deleted from its current location and is 
copied into an invisible clipboard.

To paste text from the clipboard:

1. Place the cursor where you want to paste text.

2. Select the Paste function. Text from the clipboard is inserted.

 

1. Click on one side of the text you 
want to select.

2. Drag the cursor to the other side of 
the text you want to select.

3. Release the mouse button. The 
selected text is highlighted.

1. Use the arrow key to move to one 
side of the text you want to select.

2. Hold down the Shift key as you use 
the arrow key to move to the other 
side of the text you want to select. 
The selected text is highlighted.

 

1. Click where you want to insert the 
text.

2. Enter the new text.

1. Use the arrow key to move to where 
you want to insert the text.

2. Enter the new text.
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To delete text:

1. Select the text you want to delete.

2. Press Delete.

To search for text:

1. Expand the data field. A freeform window appears.

2. Select the Search button. The Search/Replace window appears.

3. Enter the search string in the Search for field.

4. Select the Search button. The window displays the area that contains the first 
occurrence of the search string.

5. Respond to the dialog boxes (if displayed) to continue the search.

6. Select the Cancel button on the Search/Replace window.

7. Select the OK button on the freeform window. 

8. Select the Save function on the main window. A dialog box appears. 

9. Press Enter.

To replace text:

1. Expand the data field. A freeform window appears.

2. Select the Search button. The Search/Replace window appears.

3. Enter the search string in the Search for field.

4. Enter the replacement string in the Replace with field.

5. To replace the next occurrence of the string, select the Replace button. You 
can continue clicking the Replace button to sequentially replace the next 
occurrence.

OR

To replace all occurrences of the string, select the Replace All button.

6. Select the Cancel button on the Search/Replace window.

7. Select the OK button on the freeform window. 
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Graphing Banner Data

The graphing feature is not 
available in Internet-native 
Banner.

Note: To use this feature, Oracle Graphics must be installed.

You can graph Banner database information without leaving Banner or without 
downloading data to another graphing tool. Graphing involves two steps:

• Designing a graph

• Building a graph

Designing a Graph

The starting point of any graph is the graph design. Banner is delivered with 
standard graph designs. You can also create your own graph designs. A graph design, 
whether delivered with the system or developed at your institution, includes six 
components:

• Product name (General, Student, Finance, Financial Aid, Human Resources, or 
Alumni/Development)

• Functional area, within the product, that has similar types of graphing 
information

• Description of data on the vertical axis

• Description of data on the horizontal axis

• SQL*Plus statement that defines the data set to be graphed

• Data fields that can be used for filtering (optional)

The Banner Finance System is delivered with standard graph designs in three 
functional areas: A/R Aging, A/R Revenue, and Operating Ledger.

Remember that you can also create your own graph designs. This is a more technical 
task and is described in Chapter 4, Proccesing, of Using SCT Banner General.

Building a Graph

You can build a graph based on any design delivered with the system or created by 
your institution. A graphing “wizard” guides you through the graph building 
process. You can optionally filter data for a specific range, year, or value.

Note: You must use a mouse with the wizard.

Warning: If the Banner database stops responding, you must close Banner and 
check to see if the Oracle Graphics batch file is still open. If the file is still 
open, you must close it before re-entering Banner and graphing.
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To build a graph:

1. Access the Graphing Wizard Form (GOAGWIZ).

2. Click the Follow Me button on the Methods window. The Graphing Selection 
window appears.

3. Click the product name.

4. Click the functional area and the Next button.

5. Click the vertical axis and the Next button.

6. Click the horizontal axis and the Next button.

7. To filter data, click the Next button and go to step 8.

OR

To bypass data filtering, click the Skip button and go to step 12.

8. Double-click the field you want to filter.

9. Double-click the operator.

10. Enter a comparison value and press Enter.

Note: You can click the Valid Values button to display a list of comparison 
values for the selected field. Double-click a value to select it.

11. If there are more filters, double-click the “And” or “Or” connector and return 
to step 8.

OR

If there are no more filters, click the Next button. The Graph Styles window 
appears.

12. Click the radio button for the desired graph and click the Next button. The 
requested graph appears.

Note: When you build the first graph in a session, it takes a while for the graph 
to appear because the Oracle Graphics batch file must be opened.

13. (Optional) To save the graph, enter the graph name in the Save Query As field, 
and click the Save Query As button.
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To display a graph that was previously saved:

1. Access the Graphing Wizard Form (GOAGWIZ).

2. Click the View Existing Graphs button on the Methods window. A list of existing 
graphs appears.

3. Double-click the name of the graph you wish to display. The requested graph 
appears.

Banner Messaging

If you have the appropriate security, you can send messages to and receive messages 
from other Banner users. Messages are created and viewed on the General Message 
Form (GUAMESG).

When you have a new message, the system displays a dialog box the next time you 
access a new form or return to the main menu: 

You can choose to display the message immediately, or you can ignore the message 
for now. You can display GUAMESG at a later time to view your messages

To display your messages at any time:

 

Click the View/Send Message button on 
the toolbar. The GUAMESG Form 
appears with your messages.

Access the GUAMESG Form.
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Customizing Banner

Some customization features 
are not available in Internet-
native Banner.

You can customize Banner to meet your individual needs. For example, you can:

• Create a personal menu.

• Customize toolbars.

• Choose what information appears in title bars.

• Specify whether form names are displayed on menus and in the navigation 
frame.

• Customize the appearance of the main menu.

Personal Menu

A personal menu includes the forms, jobs, menus, and QuickFlows that are most 
important in your daily work. You can access your personal menu from the main 
menu. It’s tied to your Oracle user ID.

You can use the following forms to create and copy personal menus:

• The Personal Menu Maintenance Form (GUAPMNU) lets you create and 
change your personal menu. The field above the right pane shows the Oracle 
user ID associated with the person logged on to the system.

• The Personal Menu Maintenance and Copy Form (GUTPMNU) lets you copy 
your personal menu to or from another user.

To use the object list to add an object to a personal menu:

Use these steps to display a list of objects and select specific objects to add to a 
personal menu.

1. Access the Personal Menu Maintenance Form (GUAPMNU).

2. Use the pull-down list above the left pane to select the object type you want to 
display. The left pane lists the objects of the selected type.

Note: You can query to reduce the object list. See the instructions on page 
2-103.

3. In the left pane, select each object you want to add to the menu. When you 
select an object, the name is highlighted.

Note: You can right-click a menu name or QuickFlow name to list the items 
associated with that object.

4. (Optional) Repeat steps 2 and 3 for each object type you want to add to the 
menu.
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Note: You can select objects from multiple object types and insert them 
together.

5. Click in the right pane where you want to place the new menu items.

6. Click the Insert Selection button in the middle of the form . The selected 
objects are added to the right pane below the place you clicked.

7. (Optional) Customize the object descriptions.

8. Select the Save function.

Select the object type
you want to display.

Select each object you
want to add to the menu.

Click in the right pane
where you want to place

the new menu items.

Click this button.

The new menu items 
are inserted below the 
cursor location.
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To add an object to a personal menu if you know the object’s name:

1. Access the Personal Menu Maintenance Form (GUAPMNU).

2. Place the cursor in a blank Name field in the right pane.

3. Enter the object’s name.

4. Press Enter. The object’s type, description, and name appear in the right pane.

5. (Optional) Customize the object description.

6. Select the Save function.

If you know the object’s name, enter the object
name in a blank Name field and press Enter.
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To query objects and add to a personal menu:

Use these steps to reduce the list of object names in the left pane. You can add any 
of the matches to your personal menu.

1. Access the Personal Menu Maintenance Form (GUAPMNU).

2. Use the pull-down list above the left pane to select the object type you want to 
query. The left pane lists the objects of the selected type.

3. Place the cursor in the left pane.

4. Select the Enter Query function. The object list disappears.

5. Enter the search criteria.

You can use the Oracle wildcards % and _. Capitalization matters. Data is 
matched against the search criteria exactly as you enter them.

6. Select the Execute Query function. The left pane lists the matching objects.

7. To add all matches to the menu (if there are 20 matches or less), click in the 
right pane where you want to place the new menu items. Then click the Insert 

All button in the middle of the form .

OR

To add selected matches to the menu, select the objects in the left pane. Click 
in the right pane where you want to place the new menu items. Then click the 
Insert Selection button in the middle of the form .

8. Select the Save function.
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Select the object type
you want to query.

Place the cursor
in the left pane.

Select Enter Query.

Enter the search criteria.

The form displays all
matching objects.

To select individual objects:
Select the objects, click in

the right pane, and click this
button.

Select Execute Query.

To select all objects
(20 or less):

Click in the right pane, and
click this button.
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To delete selected objects from a personal menu:

1. Access the Personal Menu Maintenance Form (GUAPMNU). 

2. In the right pane, select each object you want to delete. When you select an 
object, the name is highlighted.

3. Click the Remove Selection button in the middle of the form . The selected 
objects are deleted.

4. Select the Save function.

Select each object you want 
to delete from the menu.

Click this button.
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To delete all objects from a personal menu:

1. Access the Personal Menu Maintenance Form (GUAPMNU). 

2. Click the Remove All button in the middle of the form .

3. Select the Save function.

To change the location of an object in a personal menu:

1. Access the Personal Menu Maintenance Form (GUAPMNU).

2. Delete the object from the menu (see the instructions on page 2-105).

3. Add the object to the menu in its new location (see the instructions on page 2-
102).

4. Select the Save function.

Click this button to
delete all menu items.
 SCT Banner Release 5.4 September 2002
2-106 Using SCT Banner Finance Confidential



Chapter 2 Using SCT Banner
To customize a lower level menu on a personal menu:

1. Access the Personal Menu Maintenance Form (GUAPMNU).

2. Select the menu in the right pane.

3. Right-click the selected menu. Contents of the menu appear in a new window.

4. Use the normal techniques to add to, change, and delete from the menu.

Note: When you change a standard menu, a dialog box appears. Select the Yes 
response to convert the standard menu to a custom menu.

5. Select the Save function.

Select the menu.

Right-click the selected menu.

Contents of the menu 
appear in a new window. 
Use normal techniques to 
add to, change, and delete 
from the menu.
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To copy a personal menu:

1. Access the Personal Menu Maintenance and Copy Form (GUTPMNU).

2. Use the pull-down list above the right pane to select the personal menu you 
want to copy. The selected personal menu appears in the right pane.

3. (Optional) Use the normal techniques to add to, change, and delete from the 
menu before it is copied. If you want to change the original menu, select the 
Save function. If you want the changes to affect the copies only, do not select 
the Save function.

4. Click the Copy button in the middle of the form . A list of user IDs appears 
in the left pane.

5. (Optional) To reduce the list of IDs, enter a partial ID in the field above the left 
pane. Start with the first character and enter as many characters as you know. 
Press Enter.

6. Select each user ID to receive the copied menu. When an ID is selected, it is 
highlighted.

7. Click the Copy to User(s) button in the middle of the form . 

8. If any of the IDs already has a personal menu, a dialog box asks if you want to 
overwrite existing personal menus.

• To overwrite all selected personal menus, click the Yes button.

• To review each ID before deciding, click the No button. A dialog box 
appears for each ID that already has a personal menu. Click Yes to 
overwrite the old menu, or click No to keep the old menu for the ID.

When the menus are copied, a message tells you how many menus were copied 
successfully.
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Select the personal 
menu you want to copy.

Contents of the personal menu 
appear in the right pane.

Click this button. A list of user 
IDs appear in the left pane.

If you want to reduce the
list of IDs, enter search

characters and press Enter.

Select each user ID to
receive the copied menu.

Click this button.

Add to, change, and delete 
from the menu, if necessary, 
before copying.
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Customized Toolbars

You can customize your toolbars as follows:

• Display or hide a toolbar.

• Display or hide bubble help.

• Add buttons to a toolbar (client/server environments only).

• Remove buttons from a toolbar (client/server environments only).

Note: The vertical toolbar is available in client/server environments only. It is 
always displayed; you cannot hide it. 

To display or hide a toolbar:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Toolbar Display Options button. 

3. To display a toolbar, select the appropriate checkbox (Display Horizontal 
Toolbar or Display Vertical Toolbar).

OR

To hide a toolbar, clear the appropriate checkbox (Display Horizontal Toolbar 
or Display Vertical Toolbar).

4. Click the OK button. A dialog box says you must exit and restart Banner to see 
the changes.

5. Click the OK button in the dialog box.

6. Exit Banner. 

7. Restart Banner to see your changes.

To display or hide bubble help:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Toolbar Display Options button.

3. Select or clear the Display Bubble Help checkbox, depending on whether you 
want to display the bubble help.

4. Click the OK button. A dialog box says you must exit and restart Banner to see 
the changes.

5. Click the OK button in the dialog box.

6. Exit Banner. 

7. Restart Banner to see your changes.
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To add buttons to a toolbar (client/server environments only):

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Select the Customize Toolbars button. The window shows the current contents 
of the toolbars and the custom buttons you can add.

3. Click and drag the desired custom button to its new location on the horizontal 
or vertical toolbar.

4. Right-click the custom button. A window appears where you can add button 
details.

5. Enter bubble help text in the Hint field.

6. Enter a program in the Program field. This is the program that runs when the 
button is clicked. It can be a Banner form or an external program.

Note: You can use the Browse button to search your hard drive for a program 
name.

7. (Optional) Enter a command line parameter in the Parameter field. Use this 
field if the calling program accepts command line parameters. For example, 
this is the URL to be executed if the program calls your Web browser. Or it can 
be a specific document if the program calls Microsoft Word.

8. Click the OK button in the details window.

9. Click the OK button in the Customize Toolbars window. A dialog box says you 
must exit and restart Banner to see the changes.

10. Exit Banner.

11. Restart Banner to see your changes.

To remove buttons from the toolbar (client/server environments only):

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Select the Customize Toolbars button. The window shows the current contents 
of the toolbars.

3. Click and drag the custom button off the horizontal or vertical toolbar.

Note: Standard buttons appear as dimmed buttons. They are controlled by your 
institution and cannot be removed or changed by individual users.

4. Click the OK button. A dialog box says you must exit and restart Banner to see 
the changes.

5. Exit Banner.

6. Restart Banner to see your changes.
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Title Bar Display Options

You can choose to display any or all of the following in title bars:

• Form names

• Release numbers

• Database instances

To select information for your title bars:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Form Display Options button.

3. Select or clear the display options, depending on the information you want to 
see on your form title bars.

4. Select the OK button. A dialog box says you must exit and restart Banner to see 
the changes.

5. Select the OK button in the dialog box.

6. Exit Banner. 

7. Restart Banner to see your changes.

Displayed Form Names

You can choose whether form names are displayed in the following places:

• Options pull-down menu

• Navigation frame (client/server environments only)

• Left pane of menu maintenance forms

If you choose to display form names in the navigation frame, the name appears as 
bubble help when you move the cursor over the navigation option.

To display or hide form names:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Form Display Options button.

3. Select an option from the Form Name Display Option pull-down list.

4. Select the OK button. A dialog box says the change has been applied.

5. Select the OK button in the dialog box.
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Note: A change to this display option occurs immediately. You do not need to 
exit Banner. However, if you change any other display options, you must 
exit and restart Banner to see the changes.

Customized Main Menu

The SCT Banner main menu appears when you first access Banner. You can 
customize the main menu as follows:

• Identify the default expanded menu in the left pane.

• Change the sizes of the left and right panes.

• Remove form names from the right pane.

• Change the order of items in the right pane.

To identify the default expanded menu in the left pane of the main menu:

1. Access the General User Preferences Maintenance Form (GUAUPRF).

2. Click the Open Menu Options button at the top of the form. The Open Menu 
Options window appears.

3. Enter the name of the menu you want to be the default in the User Default 
field. You must use a menu name that is defined as a menu object on the Object 
Maintenance Form (GUAOBJS).

4. Click the OK button. A dialog box says you must exit and restart Banner to see 
the changes.

5. Exit Banner.

6. Restart Banner to see your changes.

To change the sizes of the left and right panes in the main menu:

1. Point your cursor to the vertical line between the left and right panes.

2. When the cursor changes to a “cross-hatch” mark, drag the line left or right to 
its new location.

Note: This change is saved when you exit Banner.

To remove form names from the right pane of the main menu:

1. Point your cursor to the vertical line between the Description and Name 
buttons at the top of the right pane.

2. When the cursor changes to a “cross-hatch” mark, drag the line to the right 
until the Name column disappears.

Note: This change is saved when you exit Banner.
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To change the order of items in the right pane of the main menu:

Click the button at the top of the column you want to use for sorting. The menu 
items are resorted. You can sort by type, description, or name.

Note: This change is not saved when you exit Banner.
 SCT Banner Release 5.4 September 2002
2-114 Using SCT Banner Finance Confidential


	Introduction
	Starting SCT Banner
	Using the Mouse and Keyboard
	Keyboard Equivalents
	Quick Reference Chart

	Naming Conventions
	What Is a Form?
	Windows
	Window Panes
	Dialog Boxes
	Alert Boxes

	Types of Forms
	Main Menu
	Application Forms
	Maintenance Forms
	Validation Forms
	Rule and Control Forms
	Inquiry and Query Forms

	Parts of a Form
	Menu Bar
	Toolbars
	Title Bar
	Navigation Frame
	Blocks
	Auto Hint
	Status Line

	Elements on a Form
	Buttons
	Checkboxes
	Radio Buttons
	Scroll Bars
	Fields
	Records, Rows, and Columns
	Pull-Down Lists

	Oracle Functions Used in Banner
	Navigating Through Banner
	Main Menu
	Direct Access
	Object Search
	Navigation Frame
	Options Menu
	Iconic Buttons
	Mouse
	Keyboard Equivalents
	QuickFlow
	Last 10 Forms in the File Pull-Down Menu

	Entering Information
	Entering Information Into Validated Fields
	Entering Information From Another Form
	Entering IDs
	Inserting New Records
	Data Format Recommendations

	Querying Information
	Query Functions
	Wildcards
	Extended Queries
	Date Queries

	Viewing Job Submission Output
	Viewing Output in Internet-Native Banner
	Viewing Output in a Client/Server Environment

	Extracting Banner �Data to a Spreadsheet
	Availability of the Extract Feature
	Extracting Data in Internet-Native Banner
	Extracting Data in a Client/Server Environment

	Using the Calendar
	Using the Calculator
	Using Help
	Online Help
	Dynamic Help
	SCT Documentation Bookshelf
	Help (Item Properties)
	Show Keys
	Auto Hint

	Using the Editor
	Graphing Banner Data
	Designing a Graph
	Building a Graph

	Banner Messaging
	Customizing Banner
	Personal Menu
	Customized Toolbars
	Title Bar Display Options
	Displayed Form Names
	Customized Main Menu


